Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456419 - yum wants to remove NetworkManager-gnome, zenity, anaconda and some other non-kde-programs when doing "yum groupremove KDE"
Summary: yum wants to remove NetworkManager-gnome, zenity, anaconda and some other non...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 466873 503268 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-23 14:00 UTC by flo
Modified: 2014-01-21 23:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-23 14:06:43 UTC


Attachments (Terms of Use)

Description flo 2008-07-23 14:00:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
when i do "yum groupremove KDE", and then i check the "remove"-list, i can see "NetworkManager-gnome", anaconda, zenity, system-config-kickstart, which are _obviously_ no KDE-programs. (anaconda and system-config kickstart is removed for dependencies, Networkmanager-gnome and zenity are normally removed.)

Version-Release number of selected component (if applicable):
yum-3.2.16-2.fc9.noarch 

How reproducible:
Always


Steps to Reproduce:
1. open a console, become root
2. enter yum groupremove KDE
3. enjoy...

Actual Results:
i saw "remove: NetworkManager-gnome  blah... blah... zenity
remove for deps: anaconda blah... system-config-kickstart"


Expected Results:
er... all those non-kde-things shouldn't be removed :D?

Additional info:
first i had KDE, then i've installed XFCE via yum groupinstall XFCE... maybe this helps?

Comment 1 seth vidal 2008-07-23 14:06:43 UTC
if you run:
yum groupinfo KDE

you'll notice that all the pkgs you listed above are, in fact, packages in the
KDE group.


Comment 2 flo 2008-07-23 14:13:55 UTC
really oO?
but why?
why is network-manager-gnome in the KDE group?
shouldn't it be in the GNOME-group??

Comment 3 seth vidal 2008-07-23 14:17:50 UTC
that's probably a question best left to the kde team or the folks who wrote the
comps file.

You can refile against comps or kde, I suspect.


Comment 4 Rex Dieter 2008-07-23 14:22:21 UTC
flo, re: comment #2
NetworkManger-gnome was included in kde-desktop because it is the best/only 
gui for NetworkManager atm.

Comment 5 Rex Dieter 2008-07-23 14:33:54 UTC
I guess it's worth mentioning 2 more things:
1.  fedora's kde implementation is kde-centric, but not a "pure" kde desktop.
2.  DE's often include overlappoing components (like NetworkManager-gnome 
here)

Comment 6 flo 2008-07-23 15:04:48 UTC
aha...
and is there any way to tell yum not  to uninstall those packets that are in
multiple groups (when one of them is installed?)


Comment 7 James Antill 2008-10-14 13:31:55 UTC
*** Bug 466873 has been marked as a duplicate of this bug. ***

Comment 8 Emanuele Bellini 2009-04-08 16:46:51 UTC
To help the descendants, you can use Yum extender to have a better control of what is going to be removed... I said a better control because some packages like gedit were removed and they weren't in the list (probably they were between the dependencies), of course if I still have the Networkmanager I can install it again...
Anyway... I'm here because I have the same issue.

Comment 9 Rex Dieter 2009-06-01 11:55:04 UTC
*** Bug 503268 has been marked as a duplicate of this bug. ***

Comment 10 Kevin Kofler 2011-10-21 06:57:42 UTC
*** Bug 747771 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.