Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456413 - RHN Satellite should allow FQDN with two parts
Summary: RHN Satellite should allow FQDN with two parts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Michael Mráka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-23 13:00 UTC by Pieter Krul
Modified: 2009-09-10 20:26 UTC (History)
1 user (show)

Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 20:26:37 UTC


Attachments (Terms of Use)
Patch to fix FQDN subroutines in rhn-base 5.x (source from spacewalk-git-20080702) (deleted)
2008-07-23 13:00 UTC, Pieter Krul
no flags Details | Diff

Description Pieter Krul 2008-07-23 13:00:16 UTC
Description of problem:
Satellite 3.6? - 5.x

When trying to install a RHN Proxy on a system that has a FQDN that is built up
as hostname.root, for example "proxy.com", the Satellite refuses to configure
the new Proxy, and returns "proxy.com does not appear to be a valid hostname",
even though it resolves fine. 

According to the Satellite, the following would be an invalid host name:

$ host redhat.com
redhat.com has address 209.132.177.50

The Satellite expects a FQDN to have at least three parts, which makes no sense,
since it is perfectly valid to use hostname.root. The Satellite software
should allow FQDN with at least two parts.

Version-Release number of selected component (if applicable):
3.6? - 5.x

How reproducible:
Always

Steps to Reproduce:
1. Install a RHN Satellite Server
2. Install a RHN Proxy Server
3. Try to "Configure RHN Proxy Server" from the RHN Satellite webGUI, and press
"Continue".
  
Actual results:

Invalid RHN Proxy Hostname: proxy.com does not appear to be a valid hostname.
Invalid RHN Parent Server: satellite.com does not appear to be a valid hostname.

Expected results:
The RHN Satellite Server recognises the valid hostnames and configures the RHN
Proxy Server

Additional info:
This also goes for the Satellite installer, where we have to use --skip-fqdn
with perfectly resolveable hosts.

Comment 1 Pieter Krul 2008-07-23 13:00:16 UTC
Created attachment 312479 [details]
Patch to fix FQDN subroutines in rhn-base 5.x (source from spacewalk-git-20080702)

Comment 2 Michael Mráka 2009-04-15 08:36:36 UTC
Verified. Satellite-5.3.0-RHEL5-re20090327.0-i386

Actvation of two part FQDN proxy works.

Comment 3 Milan Zázrivec 2009-08-14 10:28:52 UTC
Verified in stage -> RELEASE_PENDING

Comment 4 Brandon Perkins 2009-09-10 20:26:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html


Note You need to log in before you can comment on or make changes to this bug.