Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456355 - Shared directory ownership of /etc/bash_completion.d
Summary: Shared directory ownership of /etc/bash_completion.d
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash-completion
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-23 03:40 UTC by Ricky Zhou
Modified: 2008-08-07 23:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-23 17:25:24 UTC


Attachments (Terms of Use)

Description Ricky Zhou 2008-07-23 03:40:15 UTC
Description of problem:

The /etc/bash_completion.d directory is owned by several packages.

Version-Release number of selected component (if applicable):

bash-completion-20060301-10

How reproducible:

Every time

Steps to Reproduce:
1. Make sure that bash-completion, monotone, git, bzr, and rpmlint are installed.
2. rpm -qf /etc/bash_completion.d
  
Actual results:

$ rpm -qf /etc/bash_completion.d
bash-completion-20060301-10.noarch
monotone-0.39-1.fc9.i386
git-1.5.5.1-1.fc9.i386
bzr-1.5-2.fc9.i386
rpmlint-0.83-1.fc9.noarch

Expected results:

$ rpm -qf /etc/bash_completion.d
bash-completion-20060301-10.noarch

Additional info:

Side note: I think there's a typo in the spec.

install -pm 644 %{SOURCE2} contrib/mock
install -pm 644 %{SOURCE3} contrib/plague-client
install -pm 644 %{SOURCE3} contrib/repomanage

should probably be:

install -pm 644 %{SOURCE2} contrib/mock
install -pm 644 %{SOURCE4} contrib/plague-client
install -pm 644 %{SOURCE3} contrib/repomanage

Comment 1 Ville Skyttä 2008-07-23 17:25:24 UTC
I don't think this is a bug, and even if it is, there's nothing that can be done
in the bash-completion package to it.

The packages that install bash completion snippets to /etc/bash_completion.d do
not appear in any way *really* dependent on bash-completion.  It's just that if
bash-completion is installed, their completions will be auto enabled by it.  If
this is the case, the dupe dir ownership is correct.  But on the other hand if
they really require bash-completion (ie. do not function without it), they
should have a dependency in place and then the duplicate dir ownership should be
dropped.

The "side note" issue is fixed in 20060301-12, thanks.  However, reporting
separate issues in separate bugs would be better from status tracking point of
view.  (Closing this one as NOTABUG because the "main" bug is not one.)

Comment 2 Fedora Update System 2008-07-23 17:26:34 UTC
bash-completion-20060301-12 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-08-07 23:51:22 UTC
bash-completion-20060301-12 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.