Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456343 - virt-manager will not allow more than one vcpu per guest
Summary: virt-manager will not allow more than one vcpu per guest
Keywords:
Status: CLOSED DUPLICATE of bug 441653
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 23:54 UTC by Liam Dennehy
Modified: 2008-09-03 20:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-03 20:31:54 UTC


Attachments (Terms of Use)

Description Liam Dennehy 2008-07-22 23:54:53 UTC
Description of problem:
unable to assign more than on vcpu using the virt-manager gui

Version-Release number of selected component (if applicable):
virt-manager-0.5.4-4.fc9

How reproducible:
always

Steps to Reproduce:
1. On a multi-core system (I have three cores)
2. Step through the virt-manager new machine wizard
  
Actual results:
Any number greater than 1 entered in the VCPUs field produces the error:
"Number of vcpus must be in the range 1-1"

Expected results:
Either a warning that I am choosing too many vcpus for my physical hardware or
no comment at all

Additional info:
I've only tried this using qemu-kvm virtualisation, but I have no others installed.

Comment 1 Cole Robinson 2008-09-03 20:31:54 UTC
virt-manager actually gets this info from libvirt, and this is a well know libvirt issue. hopefully it will be resolved for f10 beta.

*** This bug has been marked as a duplicate of bug 441653 ***


Note You need to log in before you can comment on or make changes to this bug.