Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456338 - unable to run yum update because blam need gecko-libs 1.9
Summary: unable to run yum update because blam need gecko-libs 1.9
Alias: None
Product: Fedora
Classification: Fedora
Component: blam
Version: 9
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-07-22 22:55 UTC by Christian Lupien
Modified: 2008-07-23 03:23 UTC (History)
1 user (show)

Fixed In Version: 1.8.5-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-07-23 03:23:46 UTC

Attachments (Terms of Use)

Description Christian Lupien 2008-07-22 22:55:03 UTC
Since the latest firefox update as been available (firefox.i386 0:3.0.1-1.fc9,
xulrunner-devel.i386 0: I have been unable to fully update my
system because blam (along with other programs) seems to require gecko-libs 1.9
and will not accept the new

The seem to be the same problem that affected gxine, see bug #455923

The package needs to be rebuilt with the new libs and might need relaxed

Comment 1 Alex Lancaster 2008-07-23 03:21:31 UTC
It's been pending for a couple of days now:

as has the Miro release but no pushes have gone out recently (don't know why no
updates have been pushed recently especially with all the breakage caused by the
xulrunner update).

Relaxed dependencies aren't really an option with any package that uses
gecko-devel-unstable (as blam does) because you can't guarantee that the API
won't change and therefore require a rebuild.

Note You need to log in before you can comment on or make changes to this bug.