Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456325 - cmdline kickstart option not honored
Summary: cmdline kickstart option not honored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.4
Hardware: i386
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Martin Sivák
QA Contact: Alexander Todorov
URL:
Whiteboard:
: 461230 499143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 21:08 UTC by Chris Lumens
Modified: 2018-10-20 03:38 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 09:55:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1306 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-09-01 10:20:11 UTC

Description Chris Lumens 2008-07-22 21:08:31 UTC
+++ This bug was initially created as a clone of Bug #456110 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017
Firefox/3.0

Description of problem:
My kickstart file includes the 'cmdline' option to select non-ncurses
installation output; I'm streaming this to the serial port (console=ttyS0) to
allow an external system to monitor installation status.

However, anaconda still uses the ncurses interface during installation.

Version-Release number of selected component (if applicable):
anaconda-10.1.1.81

How reproducible:
Always


Steps to Reproduce:
Boot a system against a kickstart file similar to the following:

auth  --useshadow  --enablemd5 
bootloader --location=mbr
zerombr
clearpart --all --initlabel --drives=sda
cmdline
firewall --disabled
firstboot --disable
keyboard us
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
url --url=http://169.254.0.1/cblr/links/CentOS-4.6-i386
# start off on the provisioning network (via DHCP); will be reconfigured later
network --bootproto=dhcp --hostname ems-worker2
reboot
rootpw --iscrypted REDACTED
selinux --disabled
skipx
timezone US/Central
install
clearpart --all --initlabel
part /boot --size=256
part pv.01 --size=500 --grow
volgroup vg01 pv.01
logvol / --vgname=vg01 --size=1000 --name=root
logvol /usr --vgname=vg01 --size=2048 --name=usr
logvol /var --vgname=vg01 --size=6000 --name=var
logvol /opt --vgname=vg01 --size=4096 --name=opt


Actual Results:
anaconda installs the system according to the directives given in the kickstart
file, but uses its ncurses interface to show status

Expected Results:
Updates on the ongoing operations taken by anaconda should have been printed to
the console in a non-curses-based (highly parsable) manner.

Additional info:

-- Additional comment from charles_duffy@dell.com on 2008-07-21 12:23 EST --
Also filed at http://bugs.centos.org/view.php?id=3008

-- Additional comment from charles_duffy@dell.com on 2008-07-21 23:39 EST --
This is not a bug in anaconda: text is being chosen over cmdline as cobbler is
adding 'text' to the kernel command line.

There doesn't appear to be a mechanism to prevent this, which I'm taking up with
the Cobbler team; in any event, it's quite certainly not an anaconda issue.

-- Additional comment from charles_duffy@dell.com on 2008-07-22 15:03 EST --
I closed this ticket in error; there is in fact a bug in anaconda head which
prevents cmdline from being respected if X is not being installed on the target.

Attaching patches against RHEL4 and RHEL5.

-- Additional comment from charles_duffy@dell.com on 2008-07-22 15:06 EST --
Created an attachment (id=312386)
rhel4 fix for cmdline being overridden by text when graphical install is
detected as unworkable


-- Additional comment from charles_duffy@dell.com on 2008-07-22 15:07 EST --
Created an attachment (id=312387)
rhel5 fix for cmdline being overridden by text when graphical install is
detected as unworkable


-- Additional comment from tru@pasteur.fr on 2008-07-22 16:51 EST --
please also add the patch listed at
https://www.redhat.com/archives/anaconda-devel-list/2008-July/msg00029.html,

thanks

Comment 1 Chris Lumens 2008-09-05 14:02:38 UTC
*** Bug 461230 has been marked as a duplicate of this bug. ***

Comment 2 Alexander Todorov 2008-09-05 14:50:32 UTC
Steps to reproduce:
1. Start a virtual guest with less than 288MB RAM (200MB, PV Xen guest) * 
2. Provide a complete kickstart file which contains 'cmdline' command
3. Proceed with install
4. X can't start (not enough memory, X not on minstg2.img) - anaconda falls
back to curses based text mode instead of going to cmdline mode.

* - in the code GUI_STAGE2_RAM 294912 = 288MB

Comment 4 RHEL Product and Program Management 2009-02-03 23:14:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Martin Sivák 2009-04-03 07:21:14 UTC
The fix will be available in anaconda 11.1.2.169

Comment 7 Niels de Vos 2009-05-08 13:36:28 UTC
Is related bug 499143 also solved with the upcoming anaconda?

Comment 8 Martin Sivák 2009-05-29 07:54:21 UTC
*** Bug 499143 has been marked as a duplicate of this bug. ***

Comment 9 Chris Ward 2009-07-03 18:05:09 UTC
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.

Comment 10 Alexander Todorov 2009-07-07 10:08:17 UTC
VERIFIED with 0701.0 tree and the steps to reproduce in comment #2

Comment 11 Charles Duffy 2009-07-28 22:51:12 UTC
Confirmed -- cannot reproduce with 5.4 beta.

Comment 13 errata-xmlrpc 2009-09-02 09:55:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html


Note You need to log in before you can comment on or make changes to this bug.