Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456299 - issue with kdm and generic-logos
Summary: issue with kdm and generic-logos
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: generic-logos
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F11Target
TreeView+ depends on / blocked
 
Reported: 2008-07-22 17:54 UTC by Sebastian Dziallas
Modified: 2009-04-22 22:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-22 22:05:03 UTC


Attachments (Terms of Use)

Description Sebastian Dziallas 2008-07-22 17:54:42 UTC
We're running into a problem when using generic-logos instead of fedora-logos,
for example on a KDE-based spin: Since generic-logos does apparently not contain
a kdm theme, the user isn't able to login (unless he has specified automatic
logon). Therefore, KDE-based spins using generic-logos are not really usable
after being installed.

Comment 1 Rex Dieter 2008-07-22 17:56:49 UTC
I'll take care of this (eventually).  My bad for adding theme stuff only to 
fedora-logos, and missing the matching bits in generic-logos. 

nobody noticed, until now, curses.  :) 

Comment 2 Bill Nottingham 2008-07-22 18:01:01 UTC
The last time I tried, KDM fell back fine without a specific theme. Is there not
a default one?

Comment 3 Rex Dieter 2008-07-22 18:08:38 UTC
Just double-checked, kdm crash-n-burn if it's configured theme cannot be found.
 (in this case, FedoraWaves).  

Fwiw, only problematic parts in fedora-logos is the ksplash theme (that does
include the fedora logo).

Comment 4 Rex Dieter 2008-07-22 18:09:52 UTC
longer-term, kdm needs fixing to fail gracefully (and possibly try some
failsafe/default theme).

Comment 5 Christopher D. Stover 2008-10-27 03:35:43 UTC
Is this still a generic-logos problem or a KDE issue Rex?  I wasn't sure whether to change the component or not based on your comments.

Comment 6 Rex Dieter 2009-04-22 20:50:05 UTC
Still a generic-logos issue (I think)... I'll try to work on this to be resolved for f11 at least.

Comment 7 Bill Nottingham 2009-04-22 22:05:03 UTC
I can't reproduce this with 11.0.0-1. Please reopen if it still fails for you.


Note You need to log in before you can comment on or make changes to this bug.