Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456293 - [Intel 5.3 FEAT] Add final branding strings for EagleLake graphics (McCreary) to graphics driver
Summary: [Intel 5.3 FEAT] Add final branding strings for EagleLake graphics (McCreary)...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810
Version: 5.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 461134
TreeView+ depends on / blocked
 
Reported: 2008-07-22 17:03 UTC by John Villalovos
Modified: 2015-05-08 13:59 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:27:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch for kenel/agp intel-agp.c to broadcast cantiga (deleted)
2008-11-17 08:12 UTC, lisa
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0160 normal SHIPPED_LIVE xorg-x11-drv-i810 enhancement update 2009-01-20 16:05:17 UTC

Description John Villalovos 2008-07-22 17:03:24 UTC
1. Feature Name:
Final branding strings for EagleLake graphics (McCreary) are available.  Please
add them to the graphics driver.

2. Description:
Architectures (mark all that apply)
x 32-bit x86
64-bit Itanium2
x 64-bit Intel EM64T

Dependencies:
External links:
Priority (H,M,L): H
Target Releases:
Target Release Date:
Drivers or hardware dependency:
Target Kernel:

3. Business Justification:
a. Why is this feature needed?
b. What hardware does this enable?
Eagle lake graphics
c. Forecast, volume or high end platform?
Volume
d. Any configuration info?
e. When needed?
f. Are there other dependencies (drivers).

4. Status:

5. Hardware to Red Hat?
I believe that Red Hat has the hardware now.

6. Partner management contact, email, phone, chat
keve.a.gabbert@intel.com

7. Partner technical contact, email, phone, chat
jvillalo@redhat.com

Comment 1 Andrius Benokraitis 2008-07-30 14:15:06 UTC
John - where are the actual strings for this located?

Comment 6 John Villalovos 2008-07-31 14:14:24 UTC
Gordon Jin gave me the following information:

http://developer.intel.com/products/desktop/chipsets/ lists the branding
names for P45/P43/G45/G43.
I don't understand why Q45/Q43/G41 are not listed.
Note P45/P43 don't have integrated gfx.


Comment 9 Ronald Pacheco 2008-08-06 18:19:14 UTC
Hardware is scheduled to be on-site (Westford, Raleigh and Brno) on 07-August.

Comment 11 Ronald Pacheco 2008-08-18 15:44:47 UTC
Until we receive word from Intel that the final working code is all upstream,
I'm going to put this into Conditional NAK: PATCH.

Comment 12 Jane Lv 2008-08-19 08:38:16 UTC
(In reply to comment #11)
> Until we receive word from Intel that the final working code is all upstream,
> I'm going to put this into Conditional NAK: PATCH.

The final branding strings are G45/G43, Q45/Q43.  The final code is all in Linus's upstream kernel and upstream projects.
 - xf86-video-intel (master branch or 2.4.* release)
 - mesa (master branch or 7.0.4 release)
 - kernel (2.6.26)

Comment 16 Ronald Pacheco 2008-09-03 17:42:15 UTC
Red Hat engineering is waiting for Intel (Keith P) to confirm that the changes upstream are final.

Comment 18 John Villalovos 2008-09-10 20:41:58 UTC
Michael Fu told me:
 Confirmed with zhenyu. G43 use the same pciid as G45. So you can just apply the patch for G41 and we're ready to go.

If you need more info then that, please let me know.  We believe that the code is upstream.

Comment 20 Jane Lv 2008-09-11 08:40:15 UTC
Correct comment #12, the final branding strings for EagleLake include G41, G45/G43, Q45/Q43.  The patch for G41 has been submitted to upstream.  Others are all in upstream code.

Comment 22 Adam Jackson 2008-09-19 19:42:17 UTC
Intel branding in 5.3 is in line with upstream, afaict.

Comment 26 lisa 2008-11-17 08:12:06 UTC
Created attachment 323743 [details]
patch for kenel/agp intel-agp.c to broadcast cantiga

Comment 27 lisa 2008-11-17 08:13:26 UTC
How about we also update the agpgart information loged in dmesg?
GM45 is still described as "Intel Integrated Graphics Device" now. attached a small patch to kernel/driver/char/agp/intel-agp.c FYI. the codes already in upstream.

Comment 28 Jane Lv 2008-11-20 02:20:11 UTC
Adam,

Comment #26 identified the missing branding code for GM45 in agpgart and the code is already in upstream now.  Could you please consider adding the patch into RHEL5.3?  Thanks.

Comment 30 Keve Gabbert 2008-11-20 18:12:56 UTC
Ron,
does Geoff need to post something here or will RH handle it?

Comment 33 Ronald Pacheco 2008-11-20 21:51:15 UTC
Keve,

We are cloning this BZ so that the kernel AGP portion can be taken care of by RH.  See https://bugzilla.redhat.com/show_bug.cgi?id=472438

Comment 35 Chris Ward 2008-11-28 07:15:10 UTC
Partners, this bug should be fixed in the latest RHEL 5.3 Snapshot. We believe that you have some interest in its correct functionality, so we're making a friendly request to send us some testing feedback. 

If you have a chance to test it, please share with us your findings. If you have successfully VERIFIED the fix, please add PartnerVerified to the Bugzilla keywords, along with a description of the results. Thanks!

Comment 36 lisa 2008-12-04 03:27:39 UTC
According to comment #12, here are some test results for RHEL5.3 SP4 to share with you:

1. Confirmed G45/G43/G41 branding info in 2D driver;
2. Confirmed G45/G43 branding info in kernel AGP; 
3. G41 branding info patch is submited to upstream already but blocked there due to lack of hardware validation. So, G41 not in upstream, not in RHEL5.3. Plan to open a new bug to track G41 kernel support.
4. Mesa 3D isn't supported on eagleLake & Cantiga in RHEL5.3.

Comment 37 Chris Ward 2008-12-04 08:17:00 UTC
According to comment #36, this bug has been VERIFIED. Please set to to ASSIGNED if you find this bug is not correctly fixed. If you encounter any new issues, clone this bug (NEW) and describe them. Thanks for the feedback!

Comment 39 errata-xmlrpc 2009-01-20 21:27:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0160.html


Note You need to log in before you can comment on or make changes to this bug.