Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456248 - DNS outage can cause cluster to die
Summary: DNS outage can cause cluster to die
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager
Version: 3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 14:10 UTC by Lon Hohberger
Modified: 2018-10-19 23:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-31 14:24:00 UTC


Attachments (Terms of Use)
Shortcuts DNS lookup if the IP tiebreaker is in dotted quad form (deleted)
2008-07-22 14:10 UTC, Lon Hohberger
no flags Details | Diff

Description Lon Hohberger 2008-07-22 14:10:36 UTC
Description of problem:

If a cluster member is the sole survivor in a 2-node cluster and a transient DNS
error occurs such that the cluster software can not do resolution of the IP
address, the cluster can "fail" to ping the tiebreaker.

Version-Release number of selected component (if applicable): 1.2.37-1.1

How reproducible: Rare

Steps to Reproduce:
1. Introduce transient network errors causing DNS to be unreachable
  
Actual results: cluster outage

Expected results: cluster stays up

Additional info: The cluster software MUST NEVER rely on DNS.  This behavior is
unacceptable.  The ping code does a gethostbyname() call when it should not. 
It's a simple fix.

Comment 1 Lon Hohberger 2008-07-22 14:10:36 UTC
Created attachment 312347 [details]
Shortcuts DNS lookup if the IP tiebreaker is in dotted quad form

Comment 2 Lon Hohberger 2008-07-22 14:31:59 UTC
This patch does not introduce any regressions into the package.

Comment 3 Lon Hohberger 2008-07-22 14:32:15 UTC
This patch does not introduce rolling-upgrade incompatibilities.

Comment 4 Lon Hohberger 2008-07-22 16:02:27 UTC
This bug could potentially affect any user who is running with an IP tiebreaker.
 The patch is low-impact and the work has been done.  I recommend including it.

Comment 5 Lon Hohberger 2008-07-31 14:24:00 UTC
You can also short-circuit DNS by placing the IP tiebreaker in /etc/hosts - even
when specifying the dotted quad address instead of the hostname.

Because this workaround exists, I am not going to fix this bugzilla.


Note You need to log in before you can comment on or make changes to this bug.