Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456239 - stale git packages interferring with latest package
Summary: stale git packages interferring with latest package
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: ActualBug
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 13:27 UTC by Brenton Leanhardt
Modified: 2013-01-10 10:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-30 09:16:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
kickstart (deleted)
2008-07-22 13:27 UTC, Brenton Leanhardt
no flags Details
screenshot from VM showing error (deleted)
2008-07-22 13:28 UTC, Brenton Leanhardt
no flags Details

Description Brenton Leanhardt 2008-07-22 13:27:22 UTC
Description of problem:
The 1.5.3 packages for git seems to be interfering at kickstart time with the
1.5.5 packages.  If a network install of Red Hat Enterprise Linux (RHEL) 5.2
includes the EPEL5 repository and tries in to install the 'git' package, the
install will exit in file conflicts between the two versions.  Internally we
have mirrored EPEL and removed the 1.5.3, but every time we have to re-mirror we
run into this problem again.

I don't exactly know why anaconda would try to pull in the git-core package when
our kickstart is simply requesting that the latested version of the git package
be installed. I will attach the kickstart in question to see if someone can see
the exact cause of the problem. 

Version-Release number of selected component (if applicable):
RHEL 5.2 (using latest Xen packages)
EPEL 5

How reproducible:
See included kickstart

Actual results:
See attached screen shot from VM

Additional info:
As an aside, I have not noticed this issue on systems that simply include EPEL
post installation and install git via yum.

Comment 1 Brenton Leanhardt 2008-07-22 13:27:24 UTC
Created attachment 312342 [details]
kickstart

Comment 2 Brenton Leanhardt 2008-07-22 13:28:40 UTC
Created attachment 312343 [details]
screenshot from VM showing error

Comment 3 Josh Boyer 2008-10-14 13:08:31 UTC
There isn't much we can do in git here...  it sounds like anaconda in RHEL gets confused and doesn't do the proper thing?

Comment 4 Todd Zullinger 2009-06-06 01:02:14 UTC
Should this be re-assigned to anaconda or closed (as CANTFIX? NOTABUG?)?

Comment 5 Joel Andres Granados 2009-06-30 09:16:17 UTC
This is something that needs to be addressed in the git spec file contained in the EPEL repository.  The solution might be for git-core to replace git.  I would open a bug for EPEL and address this issue there.


Note You need to log in before you can comment on or make changes to this bug.