Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456226 - radeonhd trashes console font after starting Xorg
Summary: radeonhd trashes console font after starting Xorg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Hans Ulrich Niedermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 12:17 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2008-11-29 11:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-29 11:51:46 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2008-07-22 12:17 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
xorg.conf (deleted)
2008-07-22 12:18 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
garbled console screen cap (deleted)
2008-07-24 01:32 UTC, Dominik 'Rathann' Mierzejewski
no flags Details

Description Dominik 'Rathann' Mierzejewski 2008-07-22 12:17:55 UTC
Description of problem:
After starting Xorg, some console font characters become garbled or missing.
Specifically, for example, space becomes a mess and '1', '/' and '-' turn into a
space.
I'll post a screenshot made with my cellphone later.

Version-Release number of selected component (if applicable):
xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9

How reproducible:
Always

Steps to Reproduce:
1. Start Xorg
2. Switch back to vt1
3. See garbled screen
  
Actual results:
Some console characters become garbled or missing.

Expected results:
Console should remain unaffected.

Comment 1 Dominik 'Rathann' Mierzejewski 2008-07-22 12:17:55 UTC
Created attachment 312336 [details]
Xorg.0.log

Comment 2 Dominik 'Rathann' Mierzejewski 2008-07-22 12:18:43 UTC
Created attachment 312337 [details]
xorg.conf

Comment 3 Dominik 'Rathann' Mierzejewski 2008-07-22 12:48:22 UTC
xorg-x11-drv-radeonhd-1.2.1-3.4.20080713git.fc9 from updates-testing exhibits
the same problem.

Comment 4 Dominik 'Rathann' Mierzejewski 2008-07-23 14:11:01 UTC
This: http://lists.opensuse.org/radeonhd/2008-06/msg00068.html seems to be the
same problem.

Comment 5 Dominik 'Rathann' Mierzejewski 2008-07-24 01:32:00 UTC
Created attachment 312527 [details]
garbled console screen cap

Comment 6 Hans Ulrich Niedermann 2008-09-06 21:21:35 UTC
For the record: The hardware (as Xorg.0.log shows) is a

ATI Technologies Inc RV630 [Radeon HD 2600 Series] rev 0

Comment 7 Egor Ushakov 2008-09-19 07:37:23 UTC
Same effect on RV770 (Radeon HD 4850) with xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9

Comment 8 Dominik 'Rathann' Mierzejewski 2008-10-29 11:01:30 UTC
For the record, I've rebuild the current rawhide srpm (xorg-x11-drv-radeonhd-1.2.3-1.2.20081014git.fc10) and the problem disappeared.

Comment 9 Hans Ulrich Niedermann 2008-11-29 11:51:46 UTC
Thanks.

Then I'll consider this fixed.


Note You need to log in before you can comment on or make changes to this bug.