Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456219 - Location and status of proc.txt are unclear, misleading.
Summary: Location and status of proc.txt are unclear, misleading.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 09:58 UTC by James R Grinter
Modified: 2013-04-15 08:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-11 09:14:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1574 normal SHIPPED_LIVE man-pages bug fix update 2009-11-11 09:13:32 UTC

Description James R Grinter 2008-07-22 09:58:49 UTC
Description of problem:

man page for proc(5) says "See Also ...
/usr/src/linux/Documentation/filesystems/proc.txt", but this is the wrong location. 

When you find it, at
/usr/share/doc/kernel-doc-2.6.18/Documentation/filesystems/proc.txt (your
kernel-doc version may vary), you discover that it seems to be out of date, as
it doesn't seem to have been updated since kernel versions 2.2.12 and 2.4.0, or
November 2000 (it's different to the one that came with RHEL4, but the average
reader may not compare them to find out, and so its contents become unclear and
questionnable.)

Version-Release number of selected component (if applicable):

2.6.18.* (though the same applies to RHEL4's 2.6.9.*)

How reproducible:

Very.

Steps to Reproduce:
1. man proc
2. yum -y install kernel-doc
3. less /usr/src/linux/Documentation/filesystems/proc.txt -- no such file
4. rpm -ql kernel-doc | fgrep proc.txt
5. less /usr/share/doc/kernel-doc-2.6.18/Documentation/filesystems/proc.txt
  
Actual results:


Expected results:


Additional info:

Comment 1 Don Domingo 2008-07-22 22:28:17 UTC
reassigning to kernel component, as i'm not sure what the proper component
should be.

in any case, ECS does not have access to documentation in question, as man pages
and other documentation noted in above description do not fall under our purview. 

also CC'ing riel@redhat.com, since his name appears in man proc.

Comment 2 Rik van Riel 2008-07-22 22:50:38 UTC
The man page for proc(5) is part of the man-pages RPM:

$ rpm -qf /usr/share/man/man5/proc.5.gz 
man-pages-2.39-10.el5


Comment 10 errata-xmlrpc 2009-11-11 09:14:02 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1574.html


Note You need to log in before you can comment on or make changes to this bug.