Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456208 - Incorrect characters for Romanian in gucharmap
Summary: Incorrect characters for Romanian in gucharmap
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gucharmap
Version: 5.4
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Marina Zhurakhinskaya
QA Contact: desktop-bugs@redhat.com
URL: http://www.secarica.ro
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-22 08:52 UTC by Răzvan Sandu
Modified: 2014-06-16 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:05:20 UTC


Attachments (Terms of Use)

Description Răzvan Sandu 2008-07-22 08:52:24 UTC
+++ This bug was initially created as a clone of Bug #456188 +++

Description of problem:

Hello,

There are 4 incorrect characters in gucharmap's Latin section for the Romanian
language.

Here are the characters that are incorrect for the Romanian language:

- Incorrect "S with cedilla below" (Unicode O1E) instead of correct "S with
comma below" (Unicode 0218);

- Incorrect "s with cedilla below" (Unicode O1F) instead of correct "s with
comma below" (Unicode 0219);

- Incorrect "T with cedilla below" (Unicode 0162) instead of correct "T with
comma below" (Unicode 021A);

- Incorrect "t with cedilla below" (Unicode 0163) instead of correct "t with
comma below" (Unicode 021B).

Please note that cedilla-below characters *are not* part of the Romanian
alphabet at all (it is simply a historical bug).


Version-Release number of selected component (if applicable):
gucharmap-2.22.1-1.fc9.x86_64
gucharmap-2.22.1-1.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Launch gucharmap
2. At left, choose Latin set of characters.
3. Select "t with cedilla below" (U+0163)
4. At bottom, Romanian language is referred in text
5. Verify the same issue for the other three characters
6. There are no characters with comma-below in the Latin set

  
Actual results:

- wrong characters (cedilla-below) are reffered as being part of the Romanian
alphabet, instead of comma-below ones;

- there are no correct comma-below characters in the Latin set, to be used in
Romanian language.


Expected results:

- character map should include comma-below characters in the Latin set, along
with the cedilla-below ones;

- correct (comma-below) characters should be reffered as being part of the
Romanian alphabet, instead of the cedilla-below ones.


Best regards,
Răzvan

Comment 1 RHEL Product and Program Management 2014-03-07 12:42:06 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-02 13:05:20 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 3 Răzvan Sandu 2014-06-16 11:36:16 UTC
Correct glyphs for Romanian language (comma-below) ARE present in the Latin set of gucharmap 2.28.2 (CentOS 6.5).

However, incorrect glyphs (cedilla-below) are still enumerated as valid for the Romanian language, which is not true (the Romanian Academy clearly states that, in Romanian, diacritics are formed by adding a *comma* below s, S, t and T).

Răzvan


Note You need to log in before you can comment on or make changes to this bug.