Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456172 - Kernel warnings from rt_read_slowunlock in -72
Summary: Kernel warnings from rt_read_slowunlock in -72
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Red Hat Real Time Maintenance
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 21:46 UTC by David Holmes
Modified: 2008-07-28 23:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-28 23:28:40 UTC


Attachments (Terms of Use)

Description David Holmes 2008-07-21 21:46:34 UTC
Description of problem:

One of our systems has the following warning repeated a number of times:
 
 WARNING: at kernel/rtmutex.c:1732 rt_read_slowunlock()
 Pid: 2723, comm: java Not tainted 2.6.24.7-72.el5rt #1
 
 Call Trace:
  [<ffffffff81285ef1>] rt_read_slowunlock+0x14c/0x43e
  [<ffffffff8105f455>] rt_mutex_up_read+0x25b/0x260
  [<ffffffff8105fd52>] rt_up_read+0x9/0xb
  [<ffffffff8105c218>] futex_lock_pi+0x877/0x963
  [<ffffffff8105e7fa>] ? rt_mutex_adjust_prio+0x35/0x3e
  [<ffffffff812861b9>] ? rt_read_slowunlock+0x414/0x43e
  [<ffffffff8105ce3b>] do_futex+0xb37/0xb57
  [<ffffffff81056a44>] ? getnstimeofday+0x31/0x88
  [<ffffffff8105d3f9>] compat_sys_futex+0xed/0x10b
  [<ffffffff8100f8c4>] ? syscall_trace_enter+0xb7/0xbb
  [<ffffffff81027a94>] cstar_do_call+0x1b/0x65
 

Clark responded with the following details:

$ addr2line --exe=/usr/lib/debug/lib/modules/2.6.24.7-72.el5rt/vmlinux
ffffffff81285ef1
/usr/src/debug/kernel-rt-2.6.24.7-72.el5rt/linux-2.6.24.7.x86_64/kernel/rtmutex.c:1732


That source line looks like this:

                    WARN_ON(!rls->list.prev || list_empty(&rls->list));


How reproducible:

unknown. There are numerous entries in the log but we don't know what executions
triggered the log entries.

Comment 1 David Holmes 2008-07-28 23:28:40 UTC
These are no longer seen with the -74 kernel.

Feel free to close.


Note You need to log in before you can comment on or make changes to this bug.