Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456160 - Channel subscription counts not 'remembered' on pagination
Summary: Channel subscription counts not 'remembered' on pagination
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 520
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Shannon Hughes
QA Contact: Brandon Perkins
URL: https://<sat>/rhn/admin/multiorg/OrgS...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 19:57 UTC by Partha Aji
Modified: 2008-09-02 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-02 16:52:00 UTC


Attachments (Terms of Use)

Description Partha Aji 2008-07-21 19:57:47 UTC
Description of problem:
When we paginate across the Org Channel Subscriptions page, the channel
entitlement numbers are  not persisted.  If the customer/user of this page has
to hit update entitlements on a per page basis the point of pagination is lost..

Version-Release number of selected component (if applicable): 5.1 and greater


How reproducible: always


Steps to Reproduce:
1. Login as sat admin and set your pagination preference to 5.
2. Make sure you have more than 5 channels synced..
3. Satellite Tools -> Organizations -> Select an org -> Subscriptions ->
Software Channel Entitlements
4. Update one of the "Proposed Totals"
5. Hit'>' to go to the next page
6. Hit'<' to go to the previous page

Notice the proposed totals are not retained :(..
  
Actual results:
Proposed totals are not retained

Expected results:
Totals on the page are retained

Additional info:

Comment 1 Brandon Perkins 2008-09-02 16:52:00 UTC

*** This bug has been marked as a duplicate of bug 361601 ***


Note You need to log in before you can comment on or make changes to this bug.