Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456114 - mpivars MANPATH incorrectly set
Summary: mpivars MANPATH incorrectly set
Keywords:
Status: CLOSED DUPLICATE of bug 455885
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmpi
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 16:02 UTC by Chris Schanzle
Modified: 2008-07-21 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-21 16:32:28 UTC


Attachments (Terms of Use)

Description Chris Schanzle 2008-07-21 16:02:53 UTC
Description of problem:
Once a system or user default of openmpi is set:

sudo mpi-selector --system --set openmpi-1.2.5-gcc-`uname -i` --yes

if MANPATH is unset by any other means, openmpi's mpivars.sh will set MANPATH
to, say,

/usr/lib/openmpi/1.2.5-gcc/share/man

Then, no other man pages can be searched.  (e.g., 'man ls' fails)

Suggested fix:
set MANPATH with trailing colon (:) if MANPATH is empty:

--- /usr/lib/openmpi/1.2.5-gcc/etc/mpivars.sh~  2008-05-25 01:28:57.000000000 -0400
+++ /usr/lib/openmpi/1.2.5-gcc/etc/mpivars.sh   2008-07-21 11:36:14.000000000 -0400
@@ -19,7 +19,7 @@
     if [ -n "$MANPATH" ]; then
        export MANPATH=/usr/lib/openmpi/1.2.5-gcc/share/man:$MANPATH
     else
-       export MANPATH=/usr/lib/openmpi/1.2.5-gcc/share/man
+       export MANPATH=/usr/lib/openmpi/1.2.5-gcc/share/man:
     fi
 fi
 

Note for this to take effect, after manual patching, must unregister and
re-register openmpi with mpi-selector so the scripts get re-copied to
/var/lib/mpi-selector/data/ (or just edit those target files directly)

The same applies to the *.csh scripts.

It's unfortunate 'man' won't find the man pages without setting MANPATH, but
from what I can tell (strace -e trace=file man mpicc  2>&1 | egrep openmpi), man
won't look in bin PATH elements "../share/man/".  Maybe a symlink to the man dir
/usr/lib/openmpi/1.2.5-gcc/man -> share/man.

Comment 1 Doug Ledford 2008-07-21 16:32:28 UTC

*** This bug has been marked as a duplicate of 455885 ***


Note You need to log in before you can comment on or make changes to this bug.