Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456112 - Kickstart installation fails with python error: ends with '/' and is not just '/'
Summary: Kickstart installation fails with python error: ends with '/' and is not just...
Keywords:
Status: CLOSED DUPLICATE of bug 442457
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 15:49 UTC by Bevis King
Modified: 2008-07-21 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-21 16:50:35 UTC


Attachments (Terms of Use)

Description Bevis King 2008-07-21 15:49:07 UTC
Description of problem:
Attempt to install Fedora 9 on Dell Optiplex GX620 fails with the following output:
  File "/usr/lib64/python2.5/site-packages/rhpxl/videocard.py", line 135, in __
nit__
    devs = [bus.get_object('org.freedesktop.Hal',x) for x in devs]
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 237, in __init__
    _dbus_bindings.validate_object_path(object_path)
ValueError: Invalid object path '/org/freedesktop/Hal/devices/storage_model_SAMS
UNG_HD160JJ/': ends with '/' and is not just '/'
install exited abnormally [1/1]

(this is all the information remaining on the console)


Version-Release number of selected component (if applicable):
Fedora 9

How reproducible:
Every time on this hardware (using kickstart)

Steps to Reproduce:
1.  Kickstart machine with DVD installation media as boot disc
  
Actual results:
Crash as per above.

Expected results:
Installation begins...

Additional info:

Comment 1 Bevis King 2008-07-21 16:00:07 UTC
Switching to a text mode install didn't help.

The Hard Drive ID as reported by the BIOS is:

SAMSUNG HD160JJ/P

Looks like the script can't cope with there being a '/' in the reported drive ID!

Ooops!


Comment 2 Bevis King 2008-07-21 16:12:02 UTC
OK, swapping the hard drive for a different one with out a / in the BIOS
reported name causes exactly the same kickstart configuration to work just fine!



Comment 3 Jeremy Katz 2008-07-21 16:50:35 UTC

*** This bug has been marked as a duplicate of 442457 ***


Note You need to log in before you can comment on or make changes to this bug.