Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456111 - Dependency bloat from standalone player
Summary: Dependency bloat from standalone player
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 15:47 UTC by Ville Skyttä
Modified: 2008-09-18 20:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-17 07:47:54 UTC


Attachments (Terms of Use)

Description Ville Skyttä 2008-07-21 15:47:01 UTC
Due to the addition of npplayer in recent nspluginwrapper packages, updating to
the latest nspluginplayer.i386 on my x86_64 system results in these new
dependencies being pulled in (all apparently recursive dependencies from libcurl):

ncurses-libs-5.6-16.20080301.fc9.i386
readline-5.2-13.fc9.i386
sqlite-3.5.6-2.fc9.i386
nss-3.12.0.3-0.9.1.fc9.i386
cyrus-sasl-lib-2.1.22-13.fc9.i386
libidn-0.6.14-7.i386
openssl-0.9.8g-9.fc9.i386
openldap-2.4.8-6.fc9.i386
libcurl-7.18.2-1.fc9.i386

I think that's somewhat excessive considering the nature and status of npplayer.
 Please consider dropping it or moving it eg. to a nspluginwrapper-standalone or
nspluginwrapper-player or something like that subpackage to avoid the dependency
bloat.

Comment 1 Martin Stransky 2008-09-17 07:47:54 UTC
libcurl is requested by NPAPI plug-ins (see Bug 460988).

Comment 2 Martin Stransky 2008-09-18 06:15:30 UTC
libcurl is requested by plugin wrapper, not by the stand-alone plugin viewer. There isn't any change when I move the plugin-player to some separated package...

But libcurl is needed by i386 npapi plugins so you need it anyway.

Comment 3 Ville Skyttä 2008-09-18 15:28:53 UTC
Yeah, the issue is most likely moot at this point, but in current F-9, npplayer is what pulls libcurl in:

$ rpm -q --filerequire nspluginwrapper.i386 | grep curl
/usr/lib/nspluginwrapper/npplayer       libX11.so.6 libXt.so.6 libatk-1.0.so.0 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) libcairo.so.2 libcurl.so.4 libdl.so.2 libgdk-x11-2.0.so.0 libgdk_pixbuf-2.0.so.0 libglib-2.0.so.0 libgmodule-2.0.so.0 libgobject-2.0.so.0 libgthread-2.0.so.0 libgtk-x11-2.0.so.0 libpango-1.0.so.0 libpangocairo-1.0.so.0 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) librt.so.1 rtld(GNU_HASH)

$ rpm -q nspluginwrapper.i386
nspluginwrapper-1.1.0-5.fc9.i386

Comment 4 Martin Stransky 2008-09-18 20:11:48 UTC
Aha, okay, but we need the libcurl anyway....


Note You need to log in before you can comment on or make changes to this bug.