Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456108 - No sound after recent(?) updates
Summary: No sound after recent(?) updates
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-utils
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 15:42 UTC by Jón Fairbairn
Modified: 2009-01-17 18:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-17 18:18:54 UTC


Attachments (Terms of Use)
outputs of lshal (deleted)
2008-07-21 15:42 UTC, Jón Fairbairn
no flags Details

Description Jón Fairbairn 2008-07-21 15:42:19 UTC
Description of problem:
Some time in the last fortnight or so, sound stopped working on my laptop (IBM
X30 (26724XG)

Version-Release number of selected component (if applicable):
alsa-lib-1.0.16-3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. aplay -d hw:0 /usr/share/sounds/startup3.wav
(or paplay or play)
2.
3.
  
Actual results:
control passes to aplay for about the right length of time,
but no sound is heard.

Expected results:
An irritating jingle should come out of the loudspeaker.

Additional info:

This all worked up to some point in the last fortnight
(presumably an update).  I'm afraid I can't say more
accurately than that because I don't make much use of the
sound when I'm at home (but I do use it when on the train,
and I'm going to be soon). The terminal bell (pcspkr) works,
sound works in Windows XP.

I've tried running with the kernel (2.6.25-14) that comes in
the installation iso, but sound still doesn't work though it
did with that kernel in the original install, so I don't think
it's a kernel problem. There's no surround sound in
gnome-volume-control, so bug #449739 doesn't apply, I've
tried muting, changing level and unmuting the pcm in
alsamixer (and gnome-volume-control) as per bug #438448#c8
to no avail, so it's not that either. 

I've tried 0,1,2,3,4 as values for the ac97_quirk parameter
to snd_intel8x0, but that just seems to modify the click
made when the module is loaded.

pavucontrol under the playback tab says "No streams
available". I don't know if that's significant because I
didn't look at it when sound was working. Under output
devices it lists

ALSA PCM on front:0 (Intel 82801CA-ICH3) via DMA

and nothing else.

lspci -nn -s 00:1f.5
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801CA/CAM AC'97
Audio Controller [8086:2485] (rev 02)

I'll attach output of
for i in $(hal-find-by-capability --capability alsa); do lshal -lu $i; done
>/tmp/hal-caps

Comment 1 Jón Fairbairn 2008-07-21 15:42:19 UTC
Created attachment 312271 [details]
outputs of lshal

Comment 2 Jón Fairbairn 2008-07-21 15:44:33 UTC
alsa-lib was maybe wrong component?

Comment 3 Jaroslav Kysela 2008-09-29 06:51:20 UTC
Try remove /etc/alsa/asound.state file and do 'reboot -f' (I know the force reboot seems ugly, but with normal reboot the old /etc/alsa/asound.state will be created again).

Also, 'alsaunmute' command might help.

Comment 4 Jón Fairbairn 2008-09-29 09:17:02 UTC
Unfortunately the installation in question is 350 miles away, so I can't help until I go back there in December (I needed sound working, so I moved Fedora to an external disc and installed Ubuntu).

Comment 5 Jón Fairbairn 2009-01-17 18:18:54 UTC
I tried the above suggestion, first taking a copy of /etc/alsa/asound.state and got sound.  I then ran a system update and rebooted.

After that, restoring the copy of asound.state didn't reproduce the problem, so I have sound but no useful info.


Note You need to log in before you can comment on or make changes to this bug.