Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456100 - rpm: Assertion `EVR != ((void *)0)' failed on invalid Version in .pc file(s)
Summary: rpm: Assertion `EVR != ((void *)0)' failed on invalid Version in .pc file(s)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10Blocker, F10FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2008-07-21 15:19 UTC by Rex Dieter
Modified: 2008-09-27 11:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-27 11:57:04 UTC


Attachments (Terms of Use)

Description Rex Dieter 2008-07-21 15:19:45 UTC
Trying to build kdeadmin pkg in rawhide fails at the end with
...
+ cp -pr AUTHORS COPYING README
/builddir/rpmbuild/BUILDROOT/kdeadmin-4.0.99-1.fc10.x86_64/usr/share/doc/kdeadmin-4.0.99
+ exit 0
rpmbuild: rpmfc.c:423: rpmfcHelper: Assertion `EVR != ((void *)0)' failed.
EXCEPTION: Command failed. See logs for output.

It's always built fine until recently in rawhide (and builds fine on stock F-9).

See also:
http://koji.fedoraproject.org/koji/taskinfo?taskID=726996

Comment 1 Panu Matilainen 2008-07-22 11:32:58 UTC
This is what the rpm pkg-config dep extraction barfs on with kdeadmin 4.0.5, I
suspect it's the same with 4.0.99:
$ pkg-config --print-provides system-tools-backends
system-tools-backends = 

Looking at the generated system-tools-backends.pc, the version information is
missing :
...
Name: gst-backends
Description: GNOME System Tools backends
Version:
Requires:
...

system-tools-backends.pc.cmake says "Version: ${VERSION}" so the root cause
seems to be version not getting populated correctly. And sure, rpm needs to
handle it better than dying on assert().

Comment 2 Rex Dieter 2008-07-22 13:22:22 UTC
thanks!  looks like a bug on our end then.

I'll defer to you whether you want to keep this open wrt:
"rpm needs to handle it better than dying on assert()"

Comment 3 Kevin Kofler 2008-07-24 17:31:47 UTC
Taking this off the KDE 4.1 blocker: it doesn't affect pushing KDE 4.1 to F9 at 
all, and we also have a workaround for Rawhide (we simply remove the 
offending .pc file, it appears to be unused anyway (crossing fingers)).

Comment 4 Panu Matilainen 2008-09-27 11:57:04 UTC
Fixed upstream so it'll bail out cleanly instead of assert(), rawhide will get it on next tarball update.


Note You need to log in before you can comment on or make changes to this bug.