Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456099 - firefox uses wrong plugin directory
Summary: firefox uses wrong plugin directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox
Version: 4.7
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 455233 (view as bug list)
Depends On:
Blocks: 456408
TreeView+ depends on / blocked
 
Reported: 2008-07-21 15:08 UTC by Martin Stransky
Modified: 2009-05-20 20:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-20 20:49:45 UTC


Attachments (Terms of Use)
proposed fix (deleted)
2008-07-21 15:13 UTC, Martin Stransky
no flags Details | Diff

Description Martin Stransky 2008-07-21 15:08:14 UTC
Description of problem:

Firefox ignores the default plug-in directory (/usr/lib/mozilla/plugins)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Stransky 2008-07-21 15:13:51 UTC
Created attachment 312269 [details]
proposed fix

Comment 8 Martin Stransky 2008-07-23 13:59:46 UTC
Added to CVS, tagged as firefox-3_0_1-3_el4

Comment 9 Martin Stransky 2008-07-24 14:45:21 UTC
*** Bug 455233 has been marked as a duplicate of this bug. ***

Comment 10 Edwin ten Brink 2008-07-25 20:09:42 UTC
This issue is also present in Fedora 9, both for firefox-3.0 and firefox-3.0.1.

A quick user workaround is (this also demonstrates the directory it expects):
# cd /usr/lib/firefox-3.0.1
# ln -s ../mozilla/plugins .
and restart firefox if it were running.

The rpm spec file (for 3.0.1) is also affected (minor issue, the plugins
directory removal should be removed):
%preun
# is it a final removal?
if [ $1 -eq 0 ]; then
  %{__rm} -rf %{mozappdir}/components
  %{__rm} -rf %{mozappdir}/extensions
  %{__rm} -rf %{mozappdir}/plugins
fi



Comment 11 Jonathan Peatfield 2008-07-28 14:09:57 UTC
Should there be a different bugzilla for this issue on el5?

I find that if with the el5 shipped firefox (firefox-3.0.1-1.el5) one can simply
make a symlink from the mozappdir to ../xulrunner-1.9/plugins and then it picks
up all the default expected plugins from that place as well as those which are
found in ../mozilla/plugins

While you are going about it could you look at adding the symlink from
defaults/autoconfig into the ...xulrunner-1.9/defaults/autoconfig location too
to allow auto-config files to work.  See #455794, #447535

Just making those two symlinks seems to be sufficient to get things working for
us with firefox-3.0.1-1.el5 (well obviously we have to drop in our auto-config
files etc but...)

 -- Jon


Comment 12 koka xiong 2008-11-24 08:13:21 UTC
java plugin does not work in firefox-3.0.4.el4.x86-64 during errata testing.
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4802695
This bug is from sun 
Description  	
Built Java Plug-in in 64-bit and support 64-bit VM on Windows/Linux/Solaris on AMD64.
xxxxx@xxxxx   2004-05-26
We will support Java Plugin/Java webstart on AMD64 arch on both Window and Linux platform.
Posted Date : 2008-10-13 19:32:26.0

Comment 13 Martin Stransky 2009-05-20 20:49:45 UTC
It's already fixed in firefox-3.0.10-1.el4.


Note You need to log in before you can comment on or make changes to this bug.