Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456077 - xvideo works badly with 1920x1080 movies, 2.2.1-14 was OK
Summary: xvideo works badly with 1920x1080 movies, 2.2.1-14 was OK
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10DesktopBlocker
TreeView+ depends on / blocked
 
Reported: 2008-07-21 12:34 UTC by Sami Farin
Modified: 2018-04-11 13:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-15 16:30:23 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2008-07-22 17:43 UTC, Sami Farin
no flags Details
Xorg.0.log (deleted)
2008-07-22 17:45 UTC, Sami Farin
no flags Details
Xorg.0.log no xorg.conf (deleted)
2008-07-31 08:48 UTC, Sami Farin
no flags Details

Description Sami Farin 2008-07-21 12:34:01 UTC
Description of problem:
xvideo works OK  for smaller videos, but 1920x1080
videos played by mplayer are jerky and there is a lot of shearing, and additionally
when I quit mplayer, there is a five second delay before it actually quits,
during which it displays two latest frames of the video repeatedly.

Jerkiness if not because of inadequate CPU power.
2.2.1-14 version of the driver works OK.

Version-Release number of selected component (if applicable):
2.3.2-2

How reproducible:
always

Steps to Reproduce:
1. mplayer -vo xv somemovie
2.
3.
  
Actual results:
as described

Expected results:
smooth play

Additional info:

I have965Q chipset, motherboard DQ965GF.
1600x1200@75Hz mode.

xvinfo for v2.3.2-2:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "Intel(R) Textured Video"
    number of ports: 16
    port base: 118
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 2
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 1920 x 1088
    Number of image formats: 5
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x434d5658 (XVMC)
        guid: 58564d43-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
  Adaptor #1: "Intel(R) Video Overlay"
    number of ports: 1
    port base: 134
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 12
      "XV_COLORKEY" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 66046)
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is -19)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 75)
      "XV_SATURATION" (range 0 to 1023)
              client settable attribute
              client gettable attribute (current value is 146)
      "XV_DOUBLE_BUFFER" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_PIPE" (range -1 to 1)
              client settable attribute
              client gettable attribute (current value is -1)
      "XV_GAMMA0" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 526344)
      "XV_GAMMA1" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 1052688)
      "XV_GAMMA2" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 2105376)
      "XV_GAMMA3" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 4210752)
      "XV_GAMMA4" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 8421504)
      "XV_GAMMA5" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 12632256)
    maximum XvImage size: 1920 x 1088
    Number of image formats: 5
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x434d5658 (XVMC)
        guid: 58564d43-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)

Comment 1 Matěj Cepl 2008-07-22 07:49:32 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Sami Farin 2008-07-22 17:43:03 UTC
Created attachment 312374 [details]
xorg.conf

Comment 3 Sami Farin 2008-07-22 17:45:08 UTC
Created attachment 312375 [details]
Xorg.0.log

Comment 4 Sami Farin 2008-07-31 08:46:55 UTC
Did not make any difference when I tried without /etc/X11/xorg.conf.


Comment 5 Sami Farin 2008-07-31 08:48:02 UTC
Created attachment 313080 [details]
Xorg.0.log no xorg.conf

Comment 6 Sami Farin 2008-08-12 13:52:37 UTC
I tried 2.4.0-1, Xorg did not start up because you had that intel-master.patch.
(EE) LoadModule: Module intel does not have a intelModuleData data object.

No clue what that patch was supposed to fix, but I removed that patch and 2.4.0-1 now works nicely with xvideo.

Comment 7 Zdenek Kabelac 2008-08-14 09:54:07 UTC
I can also see the error message in my Xorg log now:

 LoadModule: Module intel does not have a intelModuleData data object.

xorg-x11-drv-i810-2.4.0-1.fc10.x86_64

Comment 8 Bastien Nocera 2008-10-03 22:24:37 UTC
Newer versions of the driver load fine. Do you still see the problem with the newer driver?

Comment 9 Sami Farin 2008-10-03 22:29:16 UTC
No.

Comment 10 Adam Jackson 2008-10-15 16:30:23 UTC
Closing per comments 6 and 9.


Note You need to log in before you can comment on or make changes to this bug.