Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456065 - Kernel hangs during ohci-hcd stress testing
Summary: Kernel hangs during ohci-hcd stress testing
Keywords:
Status: CLOSED DUPLICATE of bug 455843
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.8
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Vitaly Mayatskikh
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-21 10:57 UTC by Vitaly Mayatskikh
Modified: 2008-07-24 06:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 06:46:17 UTC


Attachments (Terms of Use)

Description Vitaly Mayatskikh 2008-07-21 10:57:47 UTC
Insert any h/w into ohci usb port, run two scripts in parallel:

$ while true; do rmmod ohci; modprobe ohci; done

$ while true; do lsusb; done > /dev/null

It's better to run 2-3 lsusb loops simultaneously. lsusb script outputs:

cannot read device descriptor No such device (19)
cannot read device descriptor No such device (19)
cannot open /proc/bus/usb/002/001, No such file or directory (2)

And kernel silently hangs in several minutes. Verified on x86_64 and ppc64 machines.

Comment 2 Vitaly Mayatskikh 2008-07-24 06:46:17 UTC

*** This bug has been marked as a duplicate of 455843 ***


Note You need to log in before you can comment on or make changes to this bug.