Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456025 - On some systems device names are not shown
Summary: On some systems device names are not shown
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lsscsi
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 23:04 UTC by Adam Huffman
Modified: 2008-12-07 04:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-21 10:57:47 UTC


Attachments (Terms of Use)

Description Adam Huffman 2008-07-20 23:04:18 UTC
Description of problem:
On some systems when I run lsscsi the final column of the output i.e. the device
names such as /dev/sda etc. is missing e.g.:

]$ lsscsi
[0:0:0:0]    disk    ATA      WDC WD5000KS-75M 2E08  -       
[0:0:1:0]    disk    ATA      HDS725050KLA360  AB5A  -       
[0:1:0:0]    disk    Dell     VIRTUAL DISK     1028  -       
[1:0:0:0]    cd/dvd  HL-DT-ST DVD+-RW GSA-H21N A105  -       
[3:0:0:0]    disk    ATA      Hitachi HDS72107 GK8O  -       
[4:0:0:0]    disk    ATA      Hitachi HDS72107 GK8O  -       
[9:0:0:0]    disk    TEAC     USB   HS-CF Card 4.00  -       
[9:0:0:1]    disk    TEAC     USB   HS-xD/SM   4.00  -       
[9:0:0:2]    disk    TEAC     USB   HS-MS Card 4.00  -       
[9:0:0:3]    disk    TEAC     USB   HS-SD Card 4.00  -  


Perhaps the package needs to be updated?  The latest upstream release is 0.21:

http://www.torque.net/scsi/lsscsi.html

Version-Release number of selected component (if applicable):
lsscsi-0.17-5.x86_64

How reproducible:
On some machines

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 bcling 2008-08-11 04:41:11 UTC
Interesting that you mention "some" machines.  It's been all machines (2.6.25 kernel) for me. 

The releases prior to 0.21 didn't fix this problem, but it's fixed now.

This should be considered a trivial update:
* 0.21 compiles, installs and runs fine from the source rpm on the project's main web page.
* There are no Red Hat specific patches in the 0.17 spec file.
* Tested on x86_64.

What do we need to do to make this happen?

Comment 2 Adam Huffman 2008-08-31 13:42:25 UTC
I can confirm that a rebuild of the upstream .src.rom fixes the problem.

I'll make a rebuilt package available on my fedorapeople space.

Comment 3 bcling 2008-10-13 00:14:19 UTC
This still hasn't been repackaged into Fedora 10... I've been running 0.21 for the last few months without issue - can we get this addressed?

Comment 4 Richard Tresidder 2008-11-04 02:05:46 UTC
Any chance of getting this back ported into FC9 also.. As this problem is present there. I've had to rebuild an external 0.21 source package to get this going.
Adam you said you placed a rebuild on your fedorapeople space?? I can't seem to find it at verdurin.fedorapeople.org.  ??
I grabbed to srpm from here.. http://sg.danny.cz/scsi/lsscsi.html and built for x86_64.
All seems to be working fine. 
Cheers
Richard

Comment 5 Fedora Update System 2008-11-04 19:48:04 UTC
lsscsi-0.21-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lsscsi-0.21-2.fc10

Comment 6 Fedora Update System 2008-11-04 19:48:45 UTC
lsscsi-0.21-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lsscsi-0.21-2.fc9

Comment 7 Fedora Update System 2008-11-04 19:49:26 UTC
lsscsi-0.21-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/lsscsi-0.21-2.fc8

Comment 8 Fedora Update System 2008-11-07 02:51:57 UTC
lsscsi-0.21-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lsscsi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9419

Comment 9 Fedora Update System 2008-11-07 02:57:58 UTC
lsscsi-0.21-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lsscsi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9489

Comment 10 Fedora Update System 2008-11-21 10:57:43 UTC
lsscsi-0.21-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-11-21 10:58:04 UTC
lsscsi-0.21-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2008-12-07 04:19:41 UTC
lsscsi-0.21-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.