Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456023 - nautilus-python extension doesn't work with present version of nautilus
Summary: nautilus-python extension doesn't work with present version of nautilus
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-python
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Trond Danielsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 22:01 UTC by Toshio Ernie Kuratomi
Modified: 2008-10-03 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-26 04:35:10 UTC


Attachments (Terms of Use)

Description Toshio Ernie Kuratomi 2008-07-20 22:01:02 UTC
Description of problem:

The python nautilus extension isn't loaded in Fedora 9.  It seems that the
nautilus in Fedora 9 has a new directory for extensions:
%{_libdir}/nautilus/extensions-2.0 and a new API.

Version-Release number of selected component (if applicable):
nautilus-2.22.5.1-1.fc9.i386
nautilus-python-0.4.3-5.fc9.i386


How reproducible:
Everytime

Steps to Reproduce:
1. ps ax|grep nautilus => Find PID of running nautilus
2. /usr/sbin/lsof -p PID |grep python
3.
  
Actual results:
The python nautilus extension is not present in the list.

Expected results:
python-nautilus is present.

Additional info:
I tried copying the python-nautilus extension over to the extensions-2.0
directory to see what would happen.  I got the following message in my
.xsession-errors::

ImportError: /usr/lib/nautilus-python/nautilus.so: undefined symbol:
nautilus_file_info_get_vfs_file_info

So there's some porting that needs to be done.

Comment 1 Toshio Kuratomi 2008-09-24 01:06:58 UTC
I took a look at whether upstream had a new release that fixes this and found this:

0.5.0:
        - Add support for submenus (Lukáš Lalinský, Sylvain Baubeau, Erik Wien)
        - Make it work with nautilus 2.22 (Brian Pepple)
        - Initialize gnomevfs explicitly (Scott Tsai)
        - Compilable with Python 2.5 (Jonathan Rogers)
        - Shutdown Python (Gustavo Carneiro)
        - Initialize PyGObject/PyGTK/PyGNOMEVFS on demand (Gustavo Carneiro)

Trondd, are you still active?  If you open the acls for nautilus-python in the package database, other people can work on an update to fix this.

https://admin.fedoraproject.org/pkgdb/packages/name/nautilus-python

Comment 2 Paul 2008-09-24 07:58:40 UTC
 (In reply to comment #0)

This also seems to make 'nautilus-bzr' and 'postr' useless, since they require 'nautilus-python'. Neither one works.

Comment 3 Trond Danielsen 2008-09-24 11:20:51 UTC
Hi everyone, and sorry for the slow reply.

I have just updated and rebuilt nautilus-python in rawhide, but I do not run rawhide myself atm so feedback from one of you would be nice.

Comment 4 Fedora Update System 2008-09-24 14:03:06 UTC
nautilus-python-0.5.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nautilus-python-0.5.1-1.fc9

Comment 5 Toshio Ernie Kuratomi 2008-09-25 21:24:51 UTC
Thanks trond and bpepple!

I've tested the fc9 update and it works sufficiently that nautilus-bzr runs.  I'll get a new nautilus-bzr package that takes advantage of that built shortly.

Comment 6 Fedora Update System 2008-10-03 22:28:48 UTC
nautilus-python-0.5.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.