Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456018 - phantom window left up after viewing acrobat file inside Firefox with mozplugger
Summary: phantom window left up after viewing acrobat file inside Firefox with mozplugger
Keywords:
Status: CLOSED DUPLICATE of bug 456016
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 19:04 UTC by Jonathan Kamens
Modified: 2018-04-11 10:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 08:36:19 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2008-07-20 19:04:03 UTC
If I get rid of the Adobe Reader plugin completely, so that mozplugger is the
plugin responsible for viewing Adobe Reader files, then when I visit such a
file, mozplugger correctly brings it up in Evince.

However, when I close the window, a weird window is left open behind it, with no
content in it.  This window is clearly owned by firefox, since when I quit
firefox, the window goes away.

This is probably related to bug 456016, but I'm not convinced it's completely a
duplicate, since the window that gets left behind after viewing with evince has
window decorations, and the window that gets left behind after viewing with
nppdf.so doesn't.

Also, if you click the X to close the strange phantom window, and then try to
visit another PDF file, firefox crashes.

Comment 1 Matěj Cepl 2008-07-22 08:36:19 UTC

*** This bug has been marked as a duplicate of 456016 ***


Note You need to log in before you can comment on or make changes to this bug.