Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456017 - wrapped Adobe 8 nppdf.so shows blank window
Summary: wrapped Adobe 8 nppdf.so shows blank window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 19:01 UTC by Jonathan Kamens
Modified: 2008-10-22 11:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-22 11:08:35 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2008-07-20 19:01:23 UTC
I have mostly current packages from Rawhide, including:

nspluginwrapper-1.1.0-3.fc9.i386
firefox-3.0.1-1.fc10.i386

I also have Adobe Reader 8 installed from the Adobe Web site (see bug 456016 for
a workaround for the rpm hang that happens while installing it).

When I allow nspluginwrapper to wrap the nppdf.so that comes with Adobe Reader,
and try to view a PDF file, I get a blank window.  When I obscure the window
with another one and then move the obscuring window, the one underneath it
doesn't redraw, so it would appear that something is hung.

This may or may not be related to bug 451610.  I'm seeing that bug on my machine
as well, but this problem seems somewhat different, since npviewer.bin isn't
actually crashing.

Note that this has worked just fine in the past.

Comment 1 Martin Stransky 2008-09-06 09:16:56 UTC
I can reproduce it with 8.1.2 adobe plugin...

Comment 2 John Reiser 2008-09-22 16:53:37 UTC
I have the same trouble in Fedora 9 with:
 firefox-3.0.1-1.fc9.i386
 AdobeReader_enu-8.1.2_SU1-1.i486.rpm

Comment 3 Martin Stransky 2008-10-20 07:31:26 UTC
This bug is caused by our power-saving patch (nspluginwrapper-0.9.91.5-sleep.patch), it fails to propagate all X events...

Comment 4 Martin Stransky 2008-10-22 11:08:35 UTC
Should by fixed by the latest update (1.1.2-3)


Note You need to log in before you can comment on or make changes to this bug.