Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456016 - phantom window left up after viewing acrobat file inside Firefox with nppdf.so
Summary: phantom window left up after viewing acrobat file inside Firefox with nppdf.so
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 456018 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 18:55 UTC by Jonathan Kamens
Modified: 2018-04-11 10:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-23 19:38:18 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2008-07-20 18:55:33 UTC
1. Install Acrobat Reader 8 RPM from Adobe.  You may find that
install_browser_plugin goes into an infinite loop while the RPM is installing. 
Adobe knows about this bug and it's supposedly fixed in the next release.  In
the meantime, to work around it:

  a. Run "killall -STOP install_browser_plugin".
  b. Load /opt/Adobe/Reader/8/Browser/install_browser_plugin into an editor,
find the line with "head -10" on it, and remove the "| head -10" from the pipe.
  c. Run "/opt/Adobe/Reader8/Browser/install_browser_plugin -silent -global
-user /opt".
  d. Run "killall -9 install_browser_plugin".
  e. The RPM installation should proceed to completion.

2. Add nppdf.so to /etc/sysconfig/nspluginwrapper, and then run
mozilla-plugin-config -r to make sure that it's really uninstalled
(nsplugginwrapper is broken right now in Rawhide and won't be able to display
Adobe Reader files in any case; I'll file a separate bug about that).

2. Remove your pluginreg.dat file to make sure you're not using cached plugin
information.

3. Start firefox.

4. Browse to a PDF file.  Note that it correctly opens with Adobe Reader inside
a firefox window.

5. Close the window with the PDF file in it.  Note that there is now a phantom
window on your screen with no window decorations that you can't get rid of.

6. Closing firefox makes the window go away.

I have pretty much all current Rawhide packages, including
firefox-3.0.1-1.fc10.i386.

Comment 1 Matěj Cepl 2008-07-22 08:36:21 UTC
*** Bug 456018 has been marked as a duplicate of this bug. ***

Comment 2 Martin Stransky 2008-10-22 11:09:45 UTC
Please check the latest nspluginwrapper update (1.1.2-3)

Comment 3 Jonathan Kamens 2008-10-23 15:32:17 UTC
Seems OK now.

Comment 4 Martin Stransky 2008-10-23 19:38:18 UTC
Okay, closing.


Note You need to log in before you can comment on or make changes to this bug.