Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456010 - /etc/event.d/rcS is not run on booting single user kernel
Summary: /etc/event.d/rcS is not run on booting single user kernel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 15:18 UTC by udo
Modified: 2014-03-17 03:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 14:45:55 UTC


Attachments (Terms of Use)

Description udo 2008-07-20 15:18:54 UTC
Description of problem:
/etc/event.d/rcS is not run on booting single user kernel


Version-Release number of selected component (if applicable): 8.76.2


How reproducible: boot into grub, edit kernel command line, add 'single', boot
kernel


Steps to Reproduce:
1. boot into grub
2. edit kernel commandline, add 'single'
3. boot kernel
  
Actual results:
Shell


Expected results:
Login prompt

Additional info:

Comment 1 Bill Nottingham 2008-07-22 14:45:55 UTC
If you boot into single user mode, rc.sysinit runs and then you get a shell;
this is the same behavior that has existed since the dawn of time in Red Hat
Linux, Fedora, and RHEL.

Comment 2 udo 2008-07-22 15:06:29 UTC
/etc/event.d/rcS could provide some security. 
I did not say it was different from previous redhat/fedora releases.
I stated it was not run.
You imply this is the expected behaviour because you want the system open
immediately to everyone who has physical access. Even this small barrier is not
in place.
Not even a hint on how to place it there.
In the `old days` we could edit the inittab. And now?

Comment 3 Bill Nottingham 2008-07-22 15:13:09 UTC
Edit rcS-sulogin.

Comment 4 Bill Nottingham 2008-07-22 15:13:28 UTC
(Note that in Fedora 10, due to an upstart update, things may move slightly.)

Comment 5 udo 2008-07-22 16:23:12 UTC
You mean it has been made ahrder to ask for a password on single user mode and
that it hasn't been documented how to do so?
I was told this change (from inittab to this) was meant as an improvement.
No I am not bashing something. I want to be able to find my way through configging.

Comment 6 Bill Nottingham 2008-07-22 17:14:05 UTC
(In reply to comment #5)
> You mean it has been made ahrder to ask for a password on single user mode and
> that it hasn't been documented how to do so?

It's changed from editing one file to editing a different file. I'm not sure how
that's harder.

It was mentioned in the release notes as:
 http://docs.fedoraproject.org/release-notes/f9/en_US/sn-System-Services.html#sn-Upstart

although there isn't a one-to-one mapping of what goes where. The comment in
inittab I suppose could be improved on sulogin, but it does give the idea of
where to look.



Note You need to log in before you can comment on or make changes to this bug.