Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456006 - gtkmozembedmm fails to meet dependencies
Summary: gtkmozembedmm fails to meet dependencies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkmozembedmm
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 10:17 UTC by Kaare Fiedler Christiansen
Modified: 2008-10-07 03:56 UTC (History)
1 user (show)

Fixed In Version: 1.4.2.cvs20060817-21.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-07 03:55:27 UTC


Attachments (Terms of Use)

Description Kaare Fiedler Christiansen 2008-07-20 10:17:56 UTC
Description of problem:

The current gtkmozembedmm package will fail to meet its dependencies, since it
requires gecko-libs=1.9, and the current version is 1.9.0.1.
Worse, if gtkmozembedmm is already installed, it will block the updates of gecko
to 1.9.0.1.

Version-Release number of selected component (if applicable):

gtkmozembedmm.i386 0:1.4.2.cvs20060817-20.fc9

How reproducible:

Always

Steps to Reproduce:
1. Run 'yum install gtkmozembedmm
2. Watch it fail

Actual results:

$ sudo yum install gtkmozembedmm
Loaded plugins: refresh-packagekit

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package gtkmozembedmm.i386 0:1.4.2.cvs20060817-20.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: gtkmozembedmm
--> Finished Dependency Resolution
gtkmozembedmm-1.4.2.cvs20060817-20.fc9.i386 from updates has depsolving problems
  --> Missing Dependency: gecko-libs = 1.9 is needed by package
gtkmozembedmm-1.4.2.cvs20060817-20.fc9.i386 (updates)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
gtkmozembedmm-1.4.2.cvs20060817-20.fc9.i386 (updates)

Expected results:

Installation of gtkmozembedmm suceeds

Additional info:

None

Comment 1 Alex Lancaster 2008-10-07 03:55:27 UTC
Appears to be fixed in:

gtkmozembedmm.x86_64 0:1.4.2.cvs20060817-21.fc9

(although this will have path upgrade problems from F-8 because NEVR of F-9 < NEVR of F-8 package).

Closing bug.  Maintainer appears to be non-responsive, last rebuild of any package  was 2008-06-03 according to:

https://koji.fedoraproject.org/koji/userinfo?userID=315

Comment 2 Alex Lancaster 2008-10-07 03:56:24 UTC
log of yum install:

# sudo yum install gtkmozembedmm
<...>
Resolving Dependencies
--> Running transaction check
---> Package gtkmozembedmm.x86_64 0:1.4.2.cvs20060817-21.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch      Version                     Repository        Size 
================================================================================
Installing:
 gtkmozembedmm    x86_64    1.4.2.cvs20060817-21.fc9    updates-newkey     42 k

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 42 k
Is this ok [y/N]: n
Exiting on user Command
Complete!


Note You need to log in before you can comment on or make changes to this bug.