Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456004 - kdm does not use /usr/share/apps/kdm/faces but /usr/share/kde4/apps/kdm/faces
Summary: kdm does not use /usr/share/apps/kdm/faces but /usr/share/kde4/apps/kdm/faces
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-20 08:52 UTC by T-Gergely
Modified: 2008-08-01 00:58 UTC (History)
6 users (show)

Fixed In Version: 4.0.99-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-27 14:39:18 UTC


Attachments (Terms of Use)

Description T-Gergely 2008-07-20 08:52:59 UTC
Description of problem:

Since FC9 broke my FC7 gdm settings, I found at
http://dunedin.lug.net.nz/forums/showthread.php?t=319843 "configure Kdm in KDE
System Settings > Advanced".
I configured the login users with their icons, but kdm still shows the default
icon until I symlink them (eg. ln -s /usr/share/apps/kdm/faces/greg.face.icon
/usr/share/kde4/apps/kdm/faces/greg.face.icon)

Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.5-3.fc9.i386
(I don't know which component is affected. Sorry.)

How reproducible:
ever

Comment 1 Kevin Kofler 2008-07-20 08:57:28 UTC
We know what's causing this, this is best fixed in kdelibs, I'll take care of 
it.

Comment 2 Kevin Kofler 2008-07-20 08:59:09 UTC
(Rex Dieter, I think this has the same root cause as the problem with the KDM 
configuration itself you noticed this week.)

Comment 3 Rex Dieter 2008-07-20 14:25:24 UTC
Yes.

(Still) want to try modifying the kstandarddirs patch as we discussed?

Comment 4 Kevin Kofler 2008-07-20 16:41:45 UTC
Yes. Done in kdelibs-4.0.99-3.fc10 in Rawhide. Need some testing before putting 
this into F9. (We'll probably want to wait for the KDE 4.1 update to put this 
into F9. Or do you think this is urgent enough to rush out an update with this 
backported to our last 4.0.5 build?)

Comment 5 T-Gergely 2008-07-20 17:24:34 UTC
(In reply to comment #4)

One thing is for sure: it's not urgent for me. :) As Gnome's user switching does
not work with kdm, I'm stuck with the new ugly gdm. Thanks, guys.



Comment 6 Kevin Kofler 2008-07-27 14:38:36 UTC
*** Bug 455623 has been marked as a duplicate of this bug. ***

Comment 7 Colin J Thomson 2008-07-31 23:20:43 UTC
Still seeing a problem here:
Unable to create folder /usr/share/apps/kdm/themes
Unable to create folder /usr/share/apps/kdm/faces
So Themes cannot be installed as per comments in bug #455623
rpm -qa|grep kdelibs
kdelibs-devel-4.1.0-2.fc9.i386
kdelibs-4.1.0-2.fc9.i386
kdelibs3-devel-3.5.9-16.fc9.i386
kdelibs-common-4.1.0-2.fc9.i386
kdelibs3-3.5.9-16.fc9.i386


Comment 8 Kevin Kofler 2008-07-31 23:40:38 UTC
Looks like bug 455623 is separate.

Actually the original report in this thread is a non-bug, it is intentional 
that KDM now uses /usr/share/kde4/apps/kdm for configuration! It would be a bug 
if it was looking in /usr/share/apps/kdm only, some things did, they should be 
fixed not to since kdelibs-4.0.99-3.fc10.

Comment 9 Colin J Thomson 2008-07-31 23:44:52 UTC
Ok thanks for the info, I see you have re-opened #455623.

Comment 10 Kevin Kofler 2008-08-01 00:36:59 UTC
Looking carefully at the issue, it turns out my change to the kstandarddirs 
patch (see comment #4) had no effect at all.

Moreover, I misunderstood the original report here, so we will track this issue 
in bug 455623 which actually fits the problem.

Closing this bug because the original report here is not a bug.

Comment 11 Kevin Kofler 2008-08-01 00:58:51 UTC
To be very clear:
* It is NOT a bug that KDM searches in /usr/share/kde4/apps/kdm/faces.
* It IS a bug that the KDM configuration uses /usr/share/apps/kdm/faces, this 
is the same bug as bug 455623 (which is why I originally closed that as a 
duplicate).


Note You need to log in before you can comment on or make changes to this bug.