Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455991 - Xfig hangs on startup
Summary: Xfig hangs on startup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xfig
Version: 9
Hardware: i386
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-19 21:13 UTC by Nineth
Modified: 2008-07-27 15:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-27 15:54:02 UTC


Attachments (Terms of Use)
/usr/share/fonts/deafult/Type1/fonts.dir (deleted)
2008-07-26 22:39 UTC, Nineth
no flags Details
xorg.log (deleted)
2008-07-26 22:42 UTC, Nineth
no flags Details

Description Nineth 2008-07-19 21:13:38 UTC
Description of problem:

Xfig hangs on startup. The UI freezes and none of the buttons or menus respond,
and has to be killed. I have the latest versions of xfig and transfig. 

Version-Release number of selected component (if applicable):

xfig-3.2.5-10.fc9.i386
transfig-3.2.5-2.fc9.i386

How reproducible: 

Everytime


Steps to Reproduce:
1. Start xfig
  

Actual results:

Xfig hangs

Expected results:


Additional info:

Comment 1 Hans de Goede 2008-07-21 08:42:54 UTC
I cannot reproduce this, perhaps there is something wrong with your
X-configuration on your system (xfig uses the legacy X-server buildin font system)

Can you try running: "xfontsel" and then choosing urw as foundry and "century
schoolbook l" as family, and see if you get a proper font display at the bottom
of the xfontsel window? If you don't have xfontsel do a
"yum install xorg-x11-utils"

If xfontsel works properly, can you try the following to see if we can get a
clue whats going on:

As root in a terminal:
yum install yum-utils
debuginfo-install xfig

And then as normal user from a terminal:
gdb xfig

This will give you a gdb prompt:
(gdb)

Type "run" here and wait a little once xfig fails to appear press CTRL-c this
should get you back the (gdb) prompt, now type "bt" and paste the output here.

Thanks!


Comment 2 Nineth 2008-07-21 14:22:54 UTC
I do not have urw under foundry or "century schoolbook l" under family. Am I
missing some package? I had done a clean fresh install of FC9. 

Comment 3 Nineth 2008-07-21 14:26:14 UTC
Here is the output from the gdb backtrace.

++++++++++++++++++++++++++++++++++++++++++++
(gdb) run
Starting program: /usr/bin/xfig-Xaw3d
^C
Program received signal SIGINT, Interrupt.
DoLayout (bbw=<value optimized out>, width=<value optimized out>, height=<value
optimized out>, reply_width=<value optimized out>, reply_height=Could not find
the frame base for "DoLayout".
) at Box.c:191
191         for (i = 0; i < bbw->composite.num_children; i++) {
Missing separate debuginfos, use: debuginfo-install e2fsprogs.i386 libXau.i386
libXcursor.i386 libXdmcp.i386 libXfixes.i386 libXrender.i386 libxcb.i386
(gdb) bt
#0  DoLayout (bbw=<value optimized out>, width=<value optimized out>,
height=<value optimized out>, reply_width=<value optimized out>,
reply_height=Could not find the frame base for "DoLayout".
) at Box.c:191
#1  0x0029d95a in PreferredSize (widget=<value optimized out>, constraint=<value
optimized out>, preferred=<value optimized out>) at Box.c:358
#2  0x00495b5c in XtQueryGeometry (widget=<value optimized out>, intended=<value
optimized out>, reply=<value optimized out>) at Geometry.c:781
#3  0x002c4d67 in ComputeLayout (widget=<value optimized out>, query=<value
optimized out>, destroy_scrollbars=<value optimized out>) at Viewport.c:589
#4  0x002c5211 in Resize (widget=Could not find the frame base for "Resize".
) at Viewport.c:856
#5  0x004ab31a in XtSetValues (w=<value optimized out>, args=<value optimized
out>, num_args=<value optimized out>) at SetValues.c:399
#6  0x080e50f1 in sel_mode_but (widget=0x99429b8, closure=0x8165e48,
event=0xbfd365a4, continue_to_dispatch=0xbfd35277 "\001\224{�\004") at
w_modepanel.c:639
#7  0x00492d6e in XtDispatchEventToWidget (widget=<value optimized out>,
event=<value optimized out>) at Event.c:874
#8  0x004935a6 in _XtDefaultDispatcher (event=<value optimized out>) at Event.c:1359
#9  0x004923c7 in XtDispatchEvent (event=<value optimized out>) at Event.c:1415
#10 0x08087385 in main (argc=Cannot access memory at address 0x2
) at main.c:1547
(gdb)

Comment 4 Hans de Goede 2008-07-21 15:23:25 UTC
(In reply to comment #2)
> I do not have urw under foundry or "century schoolbook l" under family. Am I
> missing some package? I had done a clean fresh install of FC9. 

Erm, thats not supposed to happen, can you do a "rpm -q urw-fonts"
and if the output is: "package urw-fonts is not installed" do a:
"yum install urw-fonts", if it is installed then please let me know and we'll
try to figure out why its not showing up in xfontsel.



Comment 5 Nineth 2008-07-21 19:11:13 UTC
Yes, it's installed. 

$ rpm -q urw-fonts
urw-fonts-2.4-5.fc9.noarch

Comment 6 Hans de Goede 2008-07-26 15:14:52 UTC
Sorry for the delay.

Hmm, so you have urw-fonts installed, then xfontsel should see them and the
reason it isn't probably is the reason why xfig is crashing (probably).

Under /usr/share/fonts/default/Type1 you should have a fonts.dir and a
fonts.scale file and those both should list all fonts in that dir.

If you don't have them you can recreate them by doing (in that dir as root):
mkfontdir > fonts.dir
mkfontscale > fonts.scale

Doing so shouldn't hurt, so if you do have them and at the end things still
don't work, you can give this a try as a last resort.

Also in /etc/X11/fontpath.d/
You should have a symlink to /usr/share/fonts/default/Type1 called
fonts-default, please verify this.

Last /etc/X11/xorg.conf should not mention anything related to fonts at all, if
it does try moving /etc/X11/xorg.conf to another location or renaming it and the
restart X (ctrl+alt+backspace kills X). X nowadays should work without any
xorg.conf at all.

If all this is ok, xfontsel really should show the urw foundry.


Comment 7 Nineth 2008-07-26 21:31:08 UTC
Yes, I have urw-fonts installed (urw-fonts-2.4-5.fc9.noarch)

I didn't have fonts.dir or fonts.scale in /usr/share/fonts/default/Type1, I
created them as you said, but xfontsel still doesn't show urw under fndry. 

I've verified that there is indeed a font-default symlink to
/usr/share/fonts/default/Type1 in /etc/X11/fontpath.d, and xorg.conf doesn't say
anything about fonts.

Comment 8 Hans de Goede 2008-07-26 21:37:40 UTC
Have you tried restarting X after creating the fonts.dir and fonts.scale files?

After creating these files you need to execute "xset fp rehash" before running
xfontsel, or restart X.

(my bad I should have said so in my earlier comment)


Comment 9 Nineth 2008-07-26 22:00:33 UTC
Okay, I now ran "xset fp rehash", and xfontsel still doesn't show them.

I also started a fresh copy of X after doing that without any xorg.conf (did
'xinit -- :1'). Still, xfontsel doesn't show those fonts.

Comment 10 Hans de Goede 2008-07-26 22:20:46 UTC
Hmm, really weird can you attach your xorg.log please?


Comment 11 Hans de Goede 2008-07-26 22:21:49 UTC
And also fonts.dir from /usr/share/fonts/default/Type1 please.


Comment 12 Nineth 2008-07-26 22:39:59 UTC
Created attachment 312719 [details]
/usr/share/fonts/deafult/Type1/fonts.dir

Comment 13 Nineth 2008-07-26 22:42:16 UTC
Created attachment 312720 [details]
xorg.log

Comment 14 Nineth 2008-07-26 22:43:42 UTC
I've attached my Xorg.1.log and fonts.dir from /usr/share/fonts/default/Type1/

Comment 15 Hans de Goede 2008-07-26 23:03:32 UTC
Your fonts.dir contains 0 fonts, are there any files beside the just generated
fonts.dir / fonts.scale in the /usr/share/fonts/default/Type1/ dir at all?


Comment 16 Nineth 2008-07-27 00:31:12 UTC
I ran mkfontdir again and now fonts.dir has entries (there are files in the
directory, but for some reason an empty fonts.dir was created earlier, I'm not
sure). I can now see urw under fndry and xfig works fine. Thanks!

/usr/share/fonts/default/Type1]$ ls
a010013l.afm  a010035l.afm  b018032l.afm  c059016l.afm  d050000l.afm 
n019004l.afm  n019043l.afm  n019064l.afm  n021023l.afm  n022004l.afm 
p052003l.afm  p052024l.afm
a010013l.pfb  a010035l.pfb  b018032l.pfb  c059016l.pfb  d050000l.pfb 
n019004l.pfb  n019043l.pfb  n019064l.pfb  n021023l.pfb  n022004l.pfb 
p052003l.pfb  p052024l.pfb
a010015l.afm  b018012l.afm  b018035l.afm  c059033l.afm  fonts.dir    
n019023l.afm  n019044l.afm  n021003l.afm  n021024l.afm  n022023l.afm 
p052004l.afm  s050000l.afm
a010015l.pfb  b018012l.pfb  b018035l.pfb  c059033l.pfb  fonts.scale  
n019023l.pfb  n019044l.pfb  n021003l.pfb  n021024l.pfb  n022023l.pfb 
p052004l.pfb  s050000l.pfb
a010033l.afm  b018015l.afm  c059013l.afm  c059036l.afm  n019003l.afm 
n019024l.afm  n019063l.afm  n021004l.afm  n022003l.afm  n022024l.afm 
p052023l.afm  z003034l.afm
a010033l.pfb  b018015l.pfb  c059013l.pfb  c059036l.pfb  n019003l.pfb 
n019024l.pfb  n019063l.pfb  n021004l.pfb  n022003l.pfb  n022024l.pfb 
p052023l.pfb  z003034l.pfb
[root@localhost /usr/share/fonts/default/Type1]$

Comment 17 Hans de Goede 2008-07-27 15:54:02 UTC
Hmm,

I just checked urw-fonts and the post install script which is supposed to create
those files looks fine, I tested it and it works fine too.

Dunno what happened on your system?

Anyways closing now.



Note You need to log in before you can comment on or make changes to this bug.