Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455986 - Tix 8.4.2 incompatibility problem with tcl/tk 8.5 (some widgets don't work).
Summary: Tix 8.4.2 incompatibility problem with tcl/tk 8.5 (some widgets don't work).
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tix
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 459039 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-19 20:30 UTC by Horacio Rodriguez Montero
Modified: 2008-11-25 14:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-25 14:22:12 UTC


Attachments (Terms of Use)

Description Horacio Rodriguez Montero 2008-07-19 20:30:21 UTC
Description of problem:
Tix is a megawidget extension for the Tcl/Tk graphical programming
language. 

The tcl and tk versions in use are 8.5.2 and tix presents some incompatibility
problems with those versions (some widgets just don't work).

Version-Release number of selected component (if applicable):
tix-8.4.2-X  with tcl 8.5.Y and tk 8.5.Y

How reproducible: very reproducible running this script:
wish << END
package require Tix
tixScrolledHList .e
exit
END

Actual results:
unknown color name "{#d9d9d9}"

Expected results:
none

Additional info:
This is because there has been a change of the way tcl converts from
sctring to/from lists. 
Tix 8.4.2 has some problems handling default widget colors that has been
fixed in Tix 8.4.3.

Please upgrade to Tix 8.4.3.

Comment 1 Guy Jennings 2008-08-19 17:16:09 UTC
*** Bug 459039 has been marked as a duplicate of this bug. ***

Comment 2 Vitezslav Crhonek 2008-11-25 14:22:12 UTC
Hi,

please see https://bugzilla.redhat.com/show_bug.cgi?id=467224.

I believe that it's the same issue. Patch backported, fixed in tix-8.4.2-6.fc9.


Note You need to log in before you can comment on or make changes to this bug.