Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455961 - libdvdnav 4.1.2 causes incompatibilities with c++ compiler
Summary: libdvdnav 4.1.2 causes incompatibilities with c++ compiler
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libdvdnav
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-19 11:52 UTC by Felix Kaechele
Modified: 2008-09-09 12:53 UTC (History)
0 users

Fixed In Version: 4.1.2-3.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 12:53:26 UTC


Attachments (Terms of Use)

Description Felix Kaechele 2008-07-19 11:52:22 UTC
While trying to build a package I'm about to submit for reviwe the current
libdvdnav 4.1.2 causes a incompatibility with the c++ compiler.

g++ -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -Wall -Woverloaded-virtual -Wno-parentheses -fPIC
-O3 -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"dvd"' -I/usr/lib/vdr/include
-I/usr/include/dvdnav dvd.c
In file included from player-dvd.h:14,
                 from dvd.h:20,
                 from dvd.c:15:
/usr/include/dvdnav/dvdnav.h:293: error: expected ',' or '...' before 'this'
make: *** [dvd.o] Error 1

The problem is already solved for SVN revision 1108. See:
http://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav/src/dvdnav.h?view=log

Comment 1 Dominik 'Rathann' Mierzejewski 2008-07-26 13:17:19 UTC
I'll fix that shortly.

Comment 2 Fedora Update System 2008-07-29 21:55:42 UTC
libdvdnav-4.1.2-2.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-07-29 21:58:01 UTC
libdvdnav-4.1.2-2.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-07-30 20:10:19 UTC
libdvdnav-4.1.2-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libdvdnav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6877

Comment 5 Felix Kaechele 2008-07-30 20:34:05 UTC
Actually this does not fix my problem because the file in question (namely
dvdnav.h) isn't being patched by the supplied patch. It is really just the
replacement of "this" with "self" as happened in
http://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav/src/dvdnav.h?r1=1045&r2=1108
When doing that manually my RPM builds fine.

Comment 6 Dominik 'Rathann' Mierzejewski 2008-07-30 20:46:38 UTC
Yes, sorry, I seem to have missed the patch for F-9 branch. Fixing.

Comment 7 Fedora Update System 2008-07-30 21:01:25 UTC
libdvdnav-4.1.2-3.fc9 has been submitted as an update for Fedora 9

Comment 8 Felix Kaechele 2008-07-31 10:17:56 UTC
Now it is fixed! Thank you.

Comment 9 Fedora Update System 2008-08-07 23:50:07 UTC
libdvdnav-4.1.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-08-07 23:54:32 UTC
libdvdnav-4.1.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.