Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455950 - yum update fails due to gecko-libs
Summary: yum update fails due to gecko-libs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-19 05:37 UTC by Christopher Beland
Modified: 2014-01-21 23:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-19 05:53:24 UTC


Attachments (Terms of Use)

Description Christopher Beland 2008-07-19 05:37:22 UTC
When I do "yum update", I get errors instead of a successful update.  This
prevents security updates from being installed.

Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package nspluginwrapper-debuginfo.i386 0:1.1.0-3.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: Miro
--> Processing Dependency: gecko-libs = 1.9 for package: gnome-python2-gtkmozembed
---> Package epiphany.i386 0:2.22.2-3.fc9 set to be updated
---> Package xulrunner.i386 0:1.9.0.1-1.fc9 set to be updated
---> Package xulrunner-debuginfo.i386 0:1.9.0.1-1.fc9 set to be updated
---> Package firefox-debuginfo.i386 0:3.0.1-1.fc9 set to be updated
---> Package nspluginwrapper.i386 0:1.1.0-3.fc9 set to be updated
---> Package firefox.i386 0:3.0.1-1.fc9 set to be updated
---> Package epiphany-debuginfo.i386 0:2.22.2-3.fc9 set to be updated
---> Package yelp.i386 0:2.22.1-4.fc9 set to be updated
---> Package yelp-debuginfo.i386 0:2.22.1-4.fc9 set to be updated
--> Finished Dependency Resolution
gnome-python2-gtkmozembed-2.19.1-16.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: gecko-libs = 1.9 is needed by package
gnome-python2-gtkmozembed-2.19.1-16.fc9.i386 (installed)
Miro-1.2.4-1.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: gecko-libs = 1.9 is needed by package
Miro-1.2.4-1.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
gnome-python2-gtkmozembed-2.19.1-16.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
Miro-1.2.4-1.fc9.i386 (installed)

Comment 1 seth vidal 2008-07-19 05:53:24 UTC
A couple of things:

1. you can use --skip-broken to make sure your security updates get applied

2. the problem that caused this issue was with some pkgs not being pushed into
the repository. That's been corrected and should, even now, be propagating out
to mirrors.


Comment 2 Christopher Beland 2008-07-19 06:10:05 UTC
Unfortunately, the security updates seem to be too closely related to the
problem to be installed.  I'm not sure why this report doesn't count as a bug,
but I'm very glad to know it's already been fixed.  Thanks for your prompt reply!

Comment 3 seth vidal 2008-07-19 06:17:18 UTC
It may be a bug, but it's not a yum bug. That's why I closed it not a bug.


Note You need to log in before you can comment on or make changes to this bug.