Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455949 - xulrunner update failed gpk-update-viewer
Summary: xulrunner update failed gpk-update-viewer
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 456185 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-19 05:36 UTC by Ziggy Dustbin
Modified: 2018-04-11 10:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-21 22:54:53 UTC


Attachments (Terms of Use)

Description Ziggy Dustbin 2008-07-19 05:36:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
More details from package updater:
xulrunner-1.9-1.fc9.x86_64 (which is newer than xulrunner-1.9-0.beta5.fc9.i386) is already installed

The package updater has two obvious bugs.
1) if the package is already installed it should warn, skip that component and continue, rather than just quitting without any possibility of getting past the problem
2) If I uncheck the xulrunner security updates in the review list, it still attempts to install them, and fails with the same message - this is obviously being ignored.  If the check box does not cause the item to be skipped then remove it, or disable it to indicate that the component is required.
I don't want to remove the xulrunner package because of the bug where it will also remove Firefox and a whole lot of other stuff that should not be touched.


Version-Release number of selected component (if applicable):
xulrunner-1.9-1.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. run the current fedora 9 update series including xulrunner-1.9-1.fc9.x86_64
2.
3.

Actual Results:


Expected Results:
if the component is already there, it should skip and continue instead of failing

Additional info:

Comment 1 Ziggy Dustbin 2008-07-19 05:37:45 UTC
this is blocking the installation of all pending updates including security updates

Comment 2 Ziggy Dustbin 2008-07-19 05:38:34 UTC
This problem is blocking all further updates including security updates.

Comment 3 Naveed Hasan 2008-07-22 04:45:19 UTC
The currently released xulrunner.x86_64 has an unnecessary dependency on
xulrunner.i386 - which should really be fixed by the maintainers ASAP. Until
then, you can workaround this and upgrade xulrunner-1.9.0.1-1.fc9.x86_64.rpm
manually using rpm with nodeps:

sudo rpm -Uvh --nodeps
http://kojipkgs.fedoraproject.org/packages/xulrunner/1.9.0.1/1.fc9/x86_64/xulrunner-1.9.0.1-1.fc9.x86_64.rpm

Then update everything else as normal with the package manager or yum. This way
you'll have the latest Firefox, et. al.

Comment 4 Matěj Cepl 2008-07-22 11:40:23 UTC
*** Bug 456185 has been marked as a duplicate of this bug. ***

Comment 5 Will Woods 2008-07-23 15:58:28 UTC
*** Bug 456185 has been marked as a duplicate of this bug. ***

Comment 6 Matěj Cepl 2008-07-29 23:54:36 UTC
Could everybody on this bug reproduce it or is it gone already?

Comment 7 Jonathan Underwood 2008-07-30 00:49:14 UTC
Wee, I worked around it by removing nspluginwrapper.i386, updating, then
reinstalling nspluginwrapper.i386. But i expect the problem is still there, as I
still have xulrunner-1.9.0.1-1.fc9.x86_64.

Comment 8 Naveed Hasan 2008-07-30 02:28:08 UTC
I worked around the issue as per my comment above
https://bugzilla.redhat.com/show_bug.cgi?id=455949#c3 so I don't have any
problems. I'm not entirely sure if the erroneous dependency was in the xulrunner
rpm or the update server metadata. Someone else who still hasn't been able to
update since mid-July might be able to enlighten us on that front.

Comment 9 Matěj Cepl 2008-09-18 15:13:08 UTC
Is there anybody here who could still hits this bug?

Comment 10 Matěj Cepl 2008-10-20 21:41:44 UTC
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

Comment 11 Matěj Cepl 2008-10-21 22:54:53 UTC
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.


Note You need to log in before you can comment on or make changes to this bug.