Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455909 - Search misses many relevant messages
Summary: Search misses many relevant messages
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 17:44 UTC by Jonathan Kamens
Modified: 2018-04-11 13:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 10:36:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 446578 None None None Never

Description Jonathan Kamens 2008-07-18 17:44:03 UTC
I have thunderbird "version 2.0.0.14 (20080501)", from the RPM
thunderbird-2.0.0.14-1.fc10.i386.

I have a "Sent Items" folder on an IMAP server.  Every single message in the
"Sent Items" folder comes from "Jonathan Kamens
<jonathan.kamens@tamalesoftware.com>".  There are currently 217 messages in the
folder.

When I select "Sender" in the quick search box, type "Jonathan", and hit Enter,
only seven matches are displayed, rather than the expected 217.  The same is
true if I search for "Kamens" or "jonathan.kamens@tamalesoftware.com".

I have tried opening the properties for the folder and rebuilding the index. 
This does not help.  I have tried unsubscribing and resubscribing to the folder.
 This does not help.  I have tried exiting and restarting thunderbird.  This
does not help.

Beagle is able to see all of the messages in the folder, once I install
beagle.xpi from the beagle build (which is missing from the beagle-thunderbird
RPM, as noted in a different bug report), so this tells me that the search which
isn't working isn't using beagle.

Edit > Find > Search Messages is also able to see all of the messages in the
folder, so whatever the problem is, it's limited to the quick search box.

Comment 1 Matěj Cepl 2008-07-22 10:36:32 UTC
We filed this bug in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=446578) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.


Note You need to log in before you can comment on or make changes to this bug.