Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455894 - Write problem to journalizing files after updating Bind
Summary: Write problem to journalizing files after updating Bind
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 16:57 UTC by Gijs
Modified: 2013-04-30 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-19 11:58:57 UTC


Attachments (Terms of Use)

Description Gijs 2008-07-18 16:57:16 UTC
Description of problem:
The access rights and ownership of the zone/journalizing files are reset to
chmod 640 and the ownership to root:named after I update Bind. Because 'dynamic
updates' requires the named server to be able to write to the journalizing
files, these default access rights won't do.

Version-Release number of selected component (if applicable):
bind-9.5.0-28.P1.fc8
bind-9.5.0-27.rc1.fc8.i386

Steps to Reproduce:
1. yum update bind
  
Actual results:
The jnl files have ownership root:named, and chmods 640.

Expected results:
Either the jnl files have ownership named:named, or they have a chmod of 660.

Additional info:
I know the problem also occurred in former versions of Bind, but I'm not sure
which version exactly.

Comment 1 Gijs 2008-07-19 11:58:38 UTC
After consulting the FC list, "Christopher K. Johnson" mentioned that dynamic
zones should be placed inside the dynamic folder (/var/named/dynamic or
/var/named/chroot/var/named/dynamic)


Note You need to log in before you can comment on or make changes to this bug.