Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455885 - Sourcing mpivars.[c]sh hides all standard manpages
Summary: Sourcing mpivars.[c]sh hides all standard manpages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmpi
Version: 5.2
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact:
URL:
Whiteboard:
: 456114 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 16:39 UTC by Michael Lampe
Modified: 2009-01-20 21:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0152 normal SHIPPED_LIVE openmpi and mvapich bug fix and enhancement update 2009-01-20 16:05:09 UTC

Description Michael Lampe 2008-07-18 16:39:22 UTC
Description of problem:

Sourcing mpivars.[c]sh hides all standard manpages

Version-Release number of selected component (if applicable):

openmpi-1.2.5-5.el5

How reproducible:

Select openmpi via mpi-selector

Steps to Reproduce:
1. 'man ls'

Actual results:

'No manual entry for ls'

Expected results:

obvious.

Additional info:

mpivars.[c]sh sets MANPATH to /usr/lib/openmpi/1.2.5-gcc/share/man if MANPATH is
not already defined. It should rather be set to
/usr/lib/openmpi/1.2.5-gcc/share/man: (mind the colon at the end).

Comment 1 Doug Ledford 2008-07-18 18:32:56 UTC
This is a known issue that will be resolved in the rhel5.3 update to openmpi
(and lam for that matter).  Although the solution will be slightly different
than what you list above.  Instead of setting MANPATH at all, if we move the man
pages to be in %{mpidir}/man instead of %{mpidir}/share/man, then man will
automatically find the man pages.

Comment 2 Doug Ledford 2008-07-21 16:32:29 UTC
*** Bug 456114 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2009-01-20 21:03:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0152.html


Note You need to log in before you can comment on or make changes to this bug.