Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455881 - nspluginwrapper out of sync with security updates for xulrunner
Summary: nspluginwrapper out of sync with security updates for xulrunner
Keywords:
Status: CLOSED DUPLICATE of bug 455803
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 15:56 UTC by Michal Jaegermann
Modified: 2008-07-18 16:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 16:28:26 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2008-07-18 15:56:29 UTC
Description of problem:
nspluginwrapper-1.1.0-2.fc9, with a build date "Tue 15 Jul 2008"
has a specific requirement for "gecko-libs = 1.9".  A _security_
update to xulrunner-1.9.0.1-1.fc9, dated "Wed 16 Jul 2008"
provides "gecko-libs = 1.9.0.1".

The net effect is that on x86_64 installation yum updates to
xulrunner to 1.9.0.1-1.fc9.x86_64 and, in order to satisfy
dependencies, to 1.9-1.fc9.i386 thus making a mess and invalidating
this security update which was supposed to happen.  It looks like
that for i386 this update will just fail (not tested).

As an extra attraction with xulrunner-1.9-1.fc9.i386 installed
'rpm -Fvh xulrunner-1.9.0.1-1.fc9.i386.rpm' just returns silently,
while one would expect an attempt to update and complaints about
dependencies, suggesting that something is wrong with an ordering.
'rpm -Uvh --oldpackage xulrunner-1.9.0.1-1.fc9.i386.rpm' indeed
comes back with "error: Failed dependencies:" unappy about
gecko-libs for both x86_64 and i386 variants of nspluginwrapper.

Version-Release number of selected component (if applicable):
nspluginwrapper-1.1.0-2.fc9
xulrunner-1.9.0.1-1.fc9

Comment 1 David Juran 2008-07-18 16:28:26 UTC
I believe this is a duplicate of bug 455803

*** This bug has been marked as a duplicate of 455803 ***


Note You need to log in before you can comment on or make changes to this bug.