Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455876 - sr# 1798266 : kde/K3B Verify data says it differs, but it does not (rounded up to 32KB)
Summary: sr# 1798266 : kde/K3B Verify data says it differs, but it does not (rounded u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: k3b
Version: 4.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 4.8
Assignee: Roman Rakus
QA Contact:
URL:
Whiteboard:
: 469084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 15:19 UTC by Alan Matsuoka
Modified: 2018-10-20 01:08 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-18 20:06:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
md5sum.patch (deleted)
2008-07-18 15:19 UTC, Alan Matsuoka
no flags Details
sysreport-root.evebe625_21jan2008.tar.bz2 (deleted)
2008-07-18 15:20 UTC, Alan Matsuoka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0958 normal SHIPPED_LIVE k3b bug fix update 2009-05-18 13:27:30 UTC

Description Alan Matsuoka 2008-07-18 15:19:39 UTC
Description of problem:

When burning a DVD image, k3b claimed the written data
would differ. This is very irritating for users (adding more confusion
to the unreliable CD and DVD burning process).

The written data does not differ, but K3B seems to
write in 32KB blocks; when the ISO image is not
on a 32KB boundary it is filled up with NULLs.

Technicalls the Image is different, but K3B should
take this into account and not complain.

How reproducible:
always

Steps to Reproduce:
Write a dvd image, as one from -
http://10.65.7.1/sysreports/495233/1798266/SUN_Ultra24_Supplemental_1.1_Bios_1.10_tools_and_drivers.iso

$ ls -sk SUN_Ultra24_Supplemental_1.1_Bios_1.10_tools_and_drivers.iso
1168952 SUN_Ultra24_Supplemental_1.1_Bios_1.10_tools_and_drivers.iso


Actual results:
k3b complains that md5sum has failed

Expected results:
md5sum is correct, as shown in RHEL5.

Additional info:
probably upstream bug - http://bugs.kde.org/show_bug.cgi?id=98385

suspected fixes -

http://websvn.kde.org/branches/k3b/0.11/kdeextragear-1/k3b/src/tools/k3bmd5job.cpp?diff_format=l&view=log#rev380065

SEG Notes:

This appears to be a bug that occurs on x86_64 systems. I couldn't reproduce the
bug on x86 and since I haven't got a DVD burner on my x86_64 box I haven't got
any way of checking to see if the patch has introduced any regressions.

It doesn't seem to have any impact on my x86 system so I'll pass the patch up to
engineering.

Comment 1 Alan Matsuoka 2008-07-18 15:19:40 UTC
Created attachment 312146 [details]
md5sum.patch

Comment 2 Alan Matsuoka 2008-07-18 15:20:43 UTC
Created attachment 312147 [details]
sysreport-root.evebe625_21jan2008.tar.bz2

Comment 3 Roman Rakus 2008-07-21 13:38:49 UTC
Patch reviewed and works.

Comment 4 Roman Rakus 2008-10-30 11:04:57 UTC
*** Bug 412031 has been marked as a duplicate of this bug. ***

Comment 5 Roman Rakus 2008-10-30 11:05:38 UTC
*** Bug 469084 has been marked as a duplicate of this bug. ***

Comment 6 RHEL Product and Program Management 2008-10-31 16:40:03 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 15 errata-xmlrpc 2009-05-18 20:06:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0958.html


Note You need to log in before you can comment on or make changes to this bug.