Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455868 - yum update will install a lot of wrong i386 dependencies on x86_64
Summary: yum update will install a lot of wrong i386 dependencies on x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 455864
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 14:08 UTC by shrek-m
Modified: 2014-01-21 23:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 14:42:07 UTC


Attachments (Terms of Use)

Description shrek-m 2008-07-18 14:08:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
yum update will install wrong i386 dependencies,
i guess the problem is xulrunner.


# rpm -qa firefox\* epiphany\* xulrunner\* yelp\*
epiphany-2.22.2-2.fc9.x86_64
epiphany-extensions-2.22.1-2.fc9.x86_64
firefox-3.0-1.fc9.x86_64
yelp-2.22.1-3.fc9.x86_64
xulrunner-1.9-1.fc9.x86_64

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
it is not a mirror problem
1. # yum clean metadata
2. disable the mirrorlist repo
3. enable baseurl fedora updates repo

Actual Results:
# LANG=C yum update firefox
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 epiphany                x86_64     2.22.2-3.fc9     updates           5.7 M
 epiphany-extensions     x86_64     2.22.1-3.fc9     updates           1.1 M
 firefox                 x86_64     3.0.1-1.fc9      updates           9.3 M
 xulrunner               x86_64     1.9.0.1-1.fc9    updates           8.7 M
 yelp                    x86_64     2.22.1-4.fc9     updates           876 k


Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 ORBit2                  i386       2.14.12-3.fc9    fedora            183 k
 alsa-lib                i386       1.0.16-3.fc9     fedora            407 k
 audiofile               i386       1:0.2.6-8.fc9    fedora            108 k
 avahi                   i386       0.6.22-10.fc9    fedora            245 k
 avahi-glib              i386       0.6.22-10.fc9    fedora             17 k
 bzip2-libs              i386       1.0.5-2.fc9      updates            38 k
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 esound-libs             i386       1:0.2.38-7.fc9   fedora             73 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 lcms-libs               i386       1.17-5.fc9       updates           106 k
 libIDL                  i386       0.8.10-2.fc9     fedora             88 k
 libacl                  i386       2.2.47-1.fc9     fedora             22 k
 libattr                 i386       2.4.41-1.fc9     fedora             13 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libdaemon               i386       0.12-3.fc9       fedora             26 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 popt                    i386       1.13-4.fc9       updates            39 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     25 Package(s)         
Update       5 Package(s)         
Remove       0 Package(s)         

Total download size: 43 M
Is this ok [y/N]: n
Exiting on user Command
Complete!

Expected Results:


Additional info:

Comment 1 James Antill 2008-07-18 14:42:07 UTC

*** This bug has been marked as a duplicate of 455864 ***


Note You need to log in before you can comment on or make changes to this bug.