Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455865 - qdiskd doesn't check the score during initialization
Summary: qdiskd doesn't check the score during initialization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
: 459692 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 13:30 UTC by Laszlo Beres
Modified: 2009-04-16 22:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:52:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0189 normal SHIPPED_LIVE cman bug-fix and enhancement update 2009-01-20 16:05:55 UTC

Description Laszlo Beres 2008-07-18 13:30:46 UTC
Description of problem:

Qdiskd starts up (with cman_stop="1") even if the score is less than minimal or
none of the heuristics was successful. 

Version-Release number of selected component (if applicable):

cman-2.0.84-2.el5

How reproducible:

Always.

Additional info:

       <quorumd device="/dev/sda1" interval="1" label="qtest" min_score="3"
tko="10" votes="3" stop_cman="1">
                <heuristic interval="2" program="[ -f /quorum ]" score="2"/>
                    <heuristic interval="2" program="/bin/ping 172.16.5.26 -c1
-t1 -W1" score="1"/>
        </quorumd>


Jul 18 15:26:21 el51 openais[31885]: [SYNC ] This node is within the primary
component and will provide service. 
Jul 18 15:26:21 el51 openais[31885]: [TOTEM] entering OPERATIONAL state. 
Jul 18 15:26:21 el51 openais[31885]: [CMAN ] quorum regained, resuming activity 
Jul 18 15:26:21 el51 openais[31885]: [CLM  ] got nodejoin message 172.16.5.16 
Jul 18 15:26:21 el51 openais[31885]: [CLM  ] got nodejoin message 172.16.5.17 
Jul 18 15:26:21 el51 openais[31885]: [CPG  ] got joinlist message from node 1 
Jul 18 15:26:21 el51 openais[31885]: [CPG  ] got joinlist message from node 2 
Jul 18 15:26:24 el51 qdiskd[31846]: <info> Node 2 is the master 
Jul 18 15:26:30 el51 qdiskd[31846]: <info> Initial score 2/3 
Jul 18 15:26:30 el51 qdiskd[31846]: <info> Initialization complete 
Jul 18 15:26:30 el51 openais[31885]: [CMAN ] quorum device registered

Comment 1 Lon Hohberger 2008-07-24 20:07:16 UTC
I have pushed this to the STABLE2, RHEL5, and MASTER branches of git.

Comment 2 Lon Hohberger 2008-08-21 11:34:27 UTC
*** Bug 459692 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2009-01-20 21:52:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html


Note You need to log in before you can comment on or make changes to this bug.