Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455850 - yum groupinstall "X Window System" rpm_check_debug vs depsolve ERROR on x86_64
Summary: yum groupinstall "X Window System" rpm_check_debug vs depsolve ERROR on x86_64
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 8
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 10:33 UTC by Bjorge Solli
Modified: 2008-10-08 16:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-08 16:50:42 UTC


Attachments (Terms of Use)
Full log of yum (deleted)
2008-07-18 10:33 UTC, Bjorge Solli
no flags Details

Description Bjorge Solli 2008-07-18 10:33:16 UTC
Description of problem:
Running this fails
# yum -y groupinstall "X Window System"

Resulting in this error:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package gtk2 needs libcups.so.2, this is not available.
Package gdm needs libattr.so.1, this is not available.
Package libgsf needs libbz2.so.1, this is not available.
Package librsvg2 needs libgnomevfs-2.so.0, this is not available.
Package libgnomecanvas needs libgailutil.so.18, this is not available.

(view log for details)

Version-Release number of selected component (if applicable):
Fedora 8 x86_64 ks-installed

How reproducible:
Every time

Additional info:
System is newly installed
I've used these fedora and fedora-updates repos:
http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/

Comment 1 Bjorge Solli 2008-07-18 10:33:16 UTC
Created attachment 312118 [details]
Full log of yum

Comment 2 Bjorge Solli 2008-07-18 12:25:04 UTC
I just verified this when using download.fedora.redhat.com as source for the
install as well.

Comment 3 Bjorge Solli 2008-07-23 15:31:34 UTC
Installing cups-libs.i386 helps on the libcups.so.2 problem, but there appears
more errors.

This should be assigned to yum.

I changed my repos to the above, did a yum clean all and then a yum upgrade.

This is on a running functioning system that has been running fine since the
early fedora 8 days, it is my workstation.

The errors produced are :
ERROR with rpm_check_debug vs depsolve:
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8,
this is not available.
Package pidgin needs libpurple = 2.4.2-1.fc8, this is not available.
Package pidgin needs libpurple = 2.4.2-1.fc8, this is not available.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8,
this is not available.

Comment 4 Bjorge Solli 2008-07-23 16:00:47 UTC
Removing .i386 libs at least fixes some of the problems. Will work to see if
that fixes all of them, but should this really be a problem?

Comment 5 Bjorge Solli 2008-07-23 16:48:39 UTC
It is possible to remove these without removing any x86_64 packages:
gail.i386
libattr.i386
bzip2-libs.i386
libpurple.i386
NetworkManager.i386
beecrypt.i386
libsysfs.i386
cyrus-sasl-lib.i386
avahi-glib.i386
libwnck.i386

These however also produce this error and can not be removed without also
removing x86_64-packages:
dbus-libs.i386
gnome-keyring.i386
gnome-keyring-devel.i386

Comment 6 Bjorge Solli 2008-07-23 16:50:35 UTC
Those packages should cover all the file conflicts/missing files I encounter
when installing/upgrading. Note that they also remove many other packages.

Comment 7 James Antill 2008-08-07 19:08:18 UTC
 Can you try the latest 3.2.18, a bug was fixed that shows up roughly like this.

Comment 8 Bjorge Solli 2008-08-12 11:43:38 UTC
(In reply to comment #7)
>  Can you try the latest 3.2.18, a bug was fixed that shows up roughly like
> this.

Can you please give me a url to that, I cannot find it.

Comment 9 Bjorge Solli 2008-08-12 12:17:04 UTC
Found a src.rpm, rebuilding myself.

Comment 10 Jan Hutař 2008-09-10 10:58:27 UTC
Hello, had new you solved the issue for you?

Comment 11 Bjorge Solli 2008-10-08 15:46:57 UTC
No. Not even 3.2.19.

Transaction Check Error:
  file /etc/gdm/securitytokens.conf from install of gdm-2.20.5-3.fc8.i386 conflicts with file from package gdm-2.20.5-3.fc8.x86_64
  file /usr/share/gdm/defaults.conf from install of gdm-2.20.5-3.fc8.i386 conflicts with file from package gdm-2.20.5-3.fc8.x86_64
  file /usr/share/gdm/factory-defaults.conf from install of gdm-2.20.5-3.fc8.i386 conflicts with file from package gdm-2.20.5-3.fc8.x86_64

Comment 12 James Antill 2008-10-08 16:50:42 UTC
 yum doesn't look for file conflicts.
 Those multilib conflicts are a packaging problem (or the .i386 package should be removed), as were the initial foo requires bar, and bar doesn't exist problems.

 Also in the default configuration yum should only install gdm.x86_64.


Note You need to log in before you can comment on or make changes to this bug.