Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455842 - Pulseaudio doesn't start, mutex error, libtool 1.5.22 incompatibility
Summary: Pulseaudio doesn't start, mutex error, libtool 1.5.22 incompatibility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pulseaudio
Version: el5
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: ActualBug
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 09:05 UTC by Emilio Scalise
Modified: 2009-09-26 01:28 UTC (History)
2 users (show)

Fixed In Version: 0.9.10-1.el5.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-26 01:28:28 UTC


Attachments (Terms of Use)
Workaround for PA to work with ltdl 1.5.22 (deleted)
2009-07-29 08:10 UTC, Michal Schmidt
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Launchpad 165220 None None None Never

Description Emilio Scalise 2008-07-18 09:05:23 UTC
Description of problem:
Pulse audio doesn't start:
$ pulseaudio
E: mutex-posix.c: Assertion 'pthread_mutex_unlock(&m->mutex) == 0' failed at
pulsecore/mutex-posix.c:98, function pa_mutex_unlock(). Aborting.
Abortito

This is due to an incompatibility with libtool 1.5.22 (see
http://www.pulseaudio.org/wiki/Incompatibilities). That's the version present in
rhel 5 (I actually use Centos 5.2 i386).

Version-Release number of selected component (if applicable):
0.9.10-1.1

How reproducible:
Try to start pulseaudio

Steps to Reproduce:
1. start pulseaudio
2.
3.
  
Actual results:
It doesn't work at all.

Expected results:


Additional info:

Comment 1 Lubomir Rintel 2008-07-21 08:28:36 UTC
Right. I've used only the client part so far...

Let me look if we can do anything on the pulseaudio side to use locks to work
around that issue.

Comment 2 Michal Schmidt 2009-04-20 13:12:23 UTC
Hi Lubomir,

did you find any workaround for the pulseaudio libtool incompatibility?

Michal

Comment 3 Lubomir Rintel 2009-04-20 13:36:48 UTC
(In reply to comment #2)
> Hi Lubomir,
> 
> did you find any workaround for the pulseaudio libtool incompatibility?

Not really. I think I asked Lennart then, and I believe the response was that there's no trivial solution. I did not look into the issue since then.

Comment 4 Michal Schmidt 2009-07-29 08:10:43 UTC
Created attachment 355504 [details]
Workaround for PA to work with ltdl 1.5.22

This patch makes PA start. See the patch description for details.

Comment 5 Michal Schmidt 2009-08-24 09:56:29 UTC
Lubomir, any comments about the proposed patch?

Comment 6 Lubomir Rintel 2009-08-24 14:42:27 UTC
Michal: Thanks for the patch, sorry for the delay, this got somehow sidetracked. Libtool is not exactly my cup of tea, as far as I can tell the patch comment makes sense to me. Thanks for the patch; I'll submit it as update and will test it for a while as well.

Comment 7 Fedora Update System 2009-08-24 14:43:48 UTC
pulseaudio-0.9.10-1.el5.3 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/pulseaudio-0.9.10-1.el5.3

Comment 8 Fedora Update System 2009-08-25 16:02:04 UTC
pulseaudio-0.9.10-1.el5.3 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pulseaudio'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0330

Comment 9 Fedora Update System 2009-09-26 01:28:22 UTC
pulseaudio-0.9.10-1.el5.3 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.