Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455830 - tail does not accept +N option
Summary: tail does not accept +N option
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 05:08 UTC by Need Real Name
Modified: 2008-07-18 07:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 07:34:55 UTC


Attachments (Terms of Use)

Description Need Real Name 2008-07-18 05:08:22 UTC
Description of problem:

   The tail program does not process the +N option. 

Version-Release number of selected component (if applicable):

    The tail program given a +N option (i.e.  tail +5 file ), should print out
the contents of file starting from line 5.  This works under other distrubtion
of linux, and is correctly documented in the man page.

How reproducible:

   always.

Steps to Reproduce:
1.  tail +5 file
2.
3.
  
Actual results:
tail: cannot open `+5' for reading: No such file or directory


Expected results:

 contents of file starting from line 5

Additional info:

Comment 1 Ondrej Vasik 2008-07-18 07:34:55 UTC
Thanks for report, however you are wrong - this works unlike with upstream under
other distribution of Linux. Additionally - man pages are not relevant
documentation for coreutils - as you can see on every single man page that you
should use info pages. You can read more about that change of behaviour at
upstream faq (
http://www.gnu.org/software/coreutils/faq/coreutils-faq.html#Old-tail-plus-N-syntax-now-fails
 ). Restoration of old (it is against latest POSIX specifications) is possible
with  setting _POSIX2_VERSION=199209 in environment - you can do that via export
or via `alias tail="_POSIX2_VERSION=199209 tail"`. Closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.