Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455822 - With net, controlled by NetworkManager and ppp connection does not work dns resolving
Summary: With net, controlled by NetworkManager and ppp connection does not work dns r...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-18 01:22 UTC by Cepreu
Modified: 2008-11-02 22:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-02 22:17:17 UTC


Attachments (Terms of Use)

Description Cepreu 2008-07-18 01:22:01 UTC
Description of problem:
With net, controlled by NetworkManager and ppp connection does not work dns
resolving

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386

Steps to Reproduce:
Way A:
1. Set up a network with following parameters: IP: 192.168.0.2, SubNet:
255.255.255.0, Default gateway: 192.168.0.1, Primary DNS: 212.122.1.2, Secondary
DNS: 212.107.200.68. If gateway for some reasons does not work, i use GPRS internet.
2. Establish GPRS connection by gnome-ppp or system-config-network.
3. Try to ping 212.122.1.2 (DNS), or mail.ru (some site)
Way B:
1. Set up a network with following parameters: IP: 192.168.0.2, SubNet:
255.255.255.0, Default gateway: 192.168.0.1, Primary DNS: 212.122.1.2, Secondary
DNS: 212.107.200.68. If gateway for some reasons does not work, i use GPRS internet.
2. Disable network manager by uncheck "Net" checkbox in context menu of nm-applet.
3. Establish GPRS connection by gnome-ppp or system-config-network.
4. Try to ping 212.122.1.2 (DNS), or mail.ru (some site)
  
Actual results:
Way A: All of pings go to gateway, but gateway does not work for now, so i does
not have net.
Way B: Ping of 212.122.1.2 work! So i have net, but...  ping mail.ru write:
ping: unknown host mail.ru. So i still have not internet!

Expected results:
Internet must work in some of ways, because in Fedora 7 i used this methods:
when gateway was not worked, i choose "No network" in knetworkmanager and then
connected to GPRS by kppp. And all was fine!

Comment 1 Dan Williams 2008-11-02 22:17:17 UTC
Should be fixed in latest NM updates (svn4022 or later).  If it's not, please paste in the contents of /etc/resolv.conf when it doesn't work.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.