Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455806 - [PATCH] Does not recognize single-quotes
Summary: [PATCH] Does not recognize single-quotes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: newsx
Version: 8
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 21:51 UTC by Enrico Scholz
Modified: 2008-09-09 12:52 UTC (History)
0 users

Fixed In Version: 1.6-9.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 12:52:49 UTC


Attachments (Terms of Use)
recognize single-quotes in innconfval output (deleted)
2008-07-17 21:51 UTC, Enrico Scholz
no flags Details | Diff

Description Enrico Scholz 2008-07-17 21:51:30 UTC
Description of problem:

At least for el5 and fedora8, inn quotes configuration variables by single quotes while 'newsx' expects double-ones. This results in errors like

| newsx: can't create lock "'/var/run/news'/L.20052": No such file or directory

This is due to

| # su - news -s /bin/sh -c /usr/lib/news/bin/innconfval\ -s
| ...
| PATHRUN='/var/run/news'; export PATHRUN;

Attached patch fixes this.


Version-Release number of selected component (if applicable):

newsx-1.6-8.fc8

Comment 1 Enrico Scholz 2008-07-17 21:51:30 UTC
Created attachment 312085 [details]
recognize single-quotes in innconfval output

Comment 2 Dominik 'Rathann' Mierzejewski 2008-07-29 06:42:06 UTC
Bug confirmed, will fix shortly.

Comment 3 Fedora Update System 2008-07-29 21:35:51 UTC
newsx-1.6-10.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-07-29 21:39:29 UTC
newsx-1.6-9.fc8 has been submitted as an update for Fedora 8

Comment 5 Dominik 'Rathann' Mierzejewski 2008-07-29 21:41:50 UTC
Thanks for the patch.

Comment 6 Fedora Update System 2008-07-30 19:59:22 UTC
newsx-1.6-9.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update newsx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6759

Comment 7 Fedora Update System 2008-08-07 23:52:11 UTC
newsx-1.6-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2008-08-07 23:55:31 UTC
newsx-1.6-10.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.