Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455803 - nspluginwrapper depends on gecko-libs = 1.9
Summary: nspluginwrapper depends on gecko-libs = 1.9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 455881 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 21:10 UTC by Reindl Harald
Modified: 2008-07-19 04:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 09:33:35 UTC


Attachments (Terms of Use)

Description Reindl Harald 2008-07-17 21:10:58 UTC
Hi, there will be a problem soon with the latest koji-builds of nspluginwrapper
and firefox-3.0.1 / xulrunner

I try to install f
irefox-3.0.1-1.fc9.x86_64.rpm 
xulruxulrunner-1.9.0.1-1.fc9.x86_64.rpmnner-1.9.0.1-1.fc9.x86_64.rpm

I have installed
nspluginwrapper-1.1.0-2.fc9.i386
nspluginwrapper-1.1.0-2.fc9.x86_64

Please solve this dependency to gecko-libs >= 1.9 and not strict to = 1.9

--> Führe Transaktionsprüfung aus                                              
                      
---> Paket firefox.x86_64 0:3.0.1-1.fc9 gesetzt um aktualisiert zu werden      
                      
---> Paket xulrunner.x86_64 0:1.9.0.1-1.fc9 gesetzt um aktualisiert zu werden  
                      
--> Verarbeite Abhängigkeiten: gecko-libs = 1.9 für Paket: nspluginwrapper     
                      
--> Verarbeite Abhängigkeiten: gecko-libs = 1.9 für Paket: nspluginwrapper

Comment 1 Tim Jackson 2008-07-18 09:21:30 UTC
This has hit in the live repos and is preventing yum updates if nspluginwrapper
is installed.

Same with totem-mozplugin, see bug #455845

Comment 2 Martin Stransky 2008-07-18 09:33:35 UTC
Should be fixed by nspluginwrapper-1.1.0-3.fc9

Comment 3 Reindl Harald 2008-07-18 09:42:59 UTC
I can confirm this after "yum --nogpgcheck localupdate"

Abhängigkeit installiert: libcurl.i386 0:7.18.2-1.fc9 nss.i386 0:3.12.0.3-0.9.1.fc9
Aktualisiert: firefox.x86_64 0:3.0.1-1.fc9 nspluginwrapper.i386 0:1.1.0-3.fc9
nspluginwrapper.x86_64 0:1.1.0-3.fc9 xulrunner.x86_64 0:1.9.0.1-1.fc9
Komplett!


Comment 4 Reindl Harald 2008-07-18 09:54:35 UTC
ERRATA: 

Can you please check plugin-detection with javascript
I see that this does not work any longer, confirming with my other machine
before update shows that it must be since the last build

before all worked fine becuase my first test for nspluginwrapper was the
following page (playing kill the process and firefox is running), the page is
unchanged but now it says there is no flash plugin

http://www.buchamzug.at/show_content.php?hid=3

____

Shockwave Flash

    Dateiname: nswrapper_32_64.libflashplayer.so
    Shockwave Flash 10.0.0 d525

MIME-Typ 	Beschreibung 	Endungen 	Aktiviert
application/x-shockwave-flash 	Shockwave Flash 	swf 	Ja
application/futuresplash 	FutureSplash Player

Comment 5 Martin Stransky 2008-07-18 10:01:31 UTC
Please run mozilla-plugin-config -i -f and attach an output of
mozilla-plugin-config -l after that.

Comment 6 Reindl Harald 2008-07-18 10:08:55 UTC
Here are the outputs
Flash works perfectly if it is called directly
But the version-check with javascript says there is no flash installed, i'm not
100% sure if this depends on flas 10 beta2, but with beta1 and nspluginwrapper
http://www.buchamzug.at/show_content.php?hid=3 worked well. 

[root@srv-rhsoft:~]$ mozilla-plugin-config -i -f
[root@srv-rhsoft:~]$ mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

/usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.nsdejavu.so
  Original plugin: /usr/lib64/mozilla/plugins/nsdejavu.so
  Wrapper version string: 1.1.0
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
/usr/lib64/mozilla/plugins-wrapped/nswrapper_32_64.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 1.1.0
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
/usr/lib64/mozilla/plugins-wrapped/nswrapper_64_64.nsdejavu.so
  Original plugin: /usr/lib64/mozilla/plugins/nsdejavu.so
  Wrapper version string: 1.1.0
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
/usr/lib64/mozilla/plugins-wrapped/nswrapper_32_64.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 1.1.0
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
[root@srv-rhsoft:~]$  

Comment 7 David Juran 2008-07-18 16:28:27 UTC
*** Bug 455881 has been marked as a duplicate of this bug. ***

Comment 8 marklf 2008-07-19 04:06:33 UTC
Same problems here today:

--> Running transaction check
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
---> Package firefox.i386 0:3.0.1-1.fc9 set to be updated
---> Package yelp.i386 0:2.22.1-4.fc9 set to be updated
---> Package xulrunner.i386 0:1.9.0.1-1.fc9 set to be updated
---> Package xulrunner-devel.i386 0:1.9.0.1-1.fc9 set to be updated
---> Package devhelp.i386 0:0.19.1-3.fc9 set to be updated
--> Finished Dependency Resolution
nspluginwrapper-1.1.0-2.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: gecko-libs = 1.9 is needed by package
nspluginwrapper-1.1.0-2.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
nspluginwrapper-1.1.0-2.fc9.i386 (installed)


Note You need to log in before you can comment on or make changes to this bug.