Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455762 - RHEL4 U6: usb test never planned
Summary: RHEL4 U6: usb test never planned
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: YangKun
QA Contact: Lawrence Lim
URL:
Whiteboard:
: 458478 468076 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 16:49 UTC by Greg Nichols
Modified: 2018-10-19 19:35 UTC (History)
8 users (show)

Fixed In Version: hts-5.2-19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-12 19:24:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0919 normal SHIPPED_LIVE hts bug fix update 2008-11-12 19:24:32 UTC

Description Greg Nichols 2008-07-17 16:49:43 UTC
Description of problem:

The USB test is never planned for RHEL4 U6,

Version-Release number of selected component (if applicable):

HTS 5.2 R19

Comment 1 YangKun 2008-08-05 08:28:47 UTC
(In reply to comment #0)
> Description of problem:
> 
> The USB test is never planned for RHEL4 U6,
> 
> Version-Release number of selected component (if applicable):
> 
> HTS 5.2 R19

fixed on 2008.08.05 . 

-YK

Comment 3 Jeremy West 2008-08-07 15:12:44 UTC
*** Bug 451867 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy West 2008-08-07 15:17:01 UTC
Do we have an ETA on what release of HTS this new patch will be available in?

--jwest

Comment 6 YangKun 2008-08-12 00:49:26 UTC
*** Bug 458478 has been marked as a duplicate of this bug. ***

Comment 11 Nicole Dai 2008-10-13 07:10:19 UTC
Verified usb test was listed in /var/hts/plan.xml after executed `hts plan` with hts-5.2-20.el4 on RHEL4U6.

Comment 12 YangKun 2008-10-23 02:10:33 UTC
*** Bug 468076 has been marked as a duplicate of this bug. ***

Comment 13 IBM Bug Proxy 2008-10-24 12:41:03 UTC
test. please ignore.
HTS-5.2-16 doesn't recognize USB ports of the system.

HTS-5.2-20 fixed the above problems. But RedHat said HTS-5.2-20 is not an
official version. So they didn't accept the test results that I submitted, and
tell I have to use HTS-5.2-16.

lspci shows there are USB ports:

[root@chevy01 hts]# lspci
00:02.0 PCI bridge: IBM EADS-X PCI-X to PCI-X Bridge (rev 03)
00:02.4 PCI bridge: IBM EADS-X PCI-X to PCI-X Bridge (rev 03)
c0:01.0 RAID bus controller: IBM Obsidian chipset SCSI controller (rev 01)
d0:01.0 USB Controller: NEC Corporation USB (rev 43)
d0:01.1 USB Controller: NEC Corporation USB (rev 43)
d0:01.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0001:01:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet
Controller (rev 06)
0001:01:00.1 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet
Controller (rev 06)
[root@chevy01 hts]#

"hts print " shows no USB:

and contents of config.xml and plan.xml:

[root@chevy01 hts]# hts print

Test Plan:
----------------------------------------------------------------
cdrom      scd0
network    eth1
network    eth0
memory
core
storage    sda
storage    sdb
storage    sdc
info
-----------
[root@chevy01 hts]# cat config.xml
<?xml version='1.0' encoding='UTF-8'?>
<certification-test discover-time='2008-10-18 00:07:58' hts-release='16'
hts-version='5.2'>
<hardware>
<arch>ppc64</arch>
<model>Power 570 Server (9117-MMA)</model>
<vendor>IBM</vendor>
<make/>
</hardware>
<certification>
<os>
<name>Nahant Update 5</name>
<release>4</release>
</os>
</certification>
</certification-test>
-----------
[root@chevy01 hts]# cat plan.xml
<?xml version='1.0' encoding='UTF-8'?>
<certification-test discover-time='2008-10-18 00:07:58' plan-time='2008-10-18
00:07:59' hts-release='16' hts-version='5.2'>
<hardware>
<arch>ppc64</arch>
<model>Power 570 Server (9117-MMA)</model>
<vendor>IBM</vendor>
<make/>
</hardware>
<certification>
<os>
<name>Nahant Update 5</name>
<release>4</release>
</os>
</certification>
<test name='cdrom' label='' logical-device='scd0' device-class='CDROM'
device-bus='SCSI' udi='' interactive='yes'/>
<test name='network' label='' logical-device='eth1' device-class='NETWORK'
device-bus='PCI' udi='' interactive='no'/>
<test name='network' label='' logical-device='eth0' device-class='NETWORK'
device-bus='PCI' udi='' interactive='no'/>
<test name='memory' label='' logical-device='' device-class='MEMORY'
device-bus='' udi='' interactive='no'/>
<test name='core' label='' logical-device='' device-class='CPU' device-bus=''
udi='' interactive='no'/>
<test name='storage' label='' logical-device='sda' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
<test name='storage' label='' logical-device='sdb' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
<test name='storage' label='' logical-device='sdc' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
<test name='info' label='' logical-device='' device-class='ALL' device-bus=''
udi='' interactive='no'/>
</certification-test>
----------------


Your operating system is RHEL4 --> "Nahant Update 5" .

"hts-5.2-16 can not add the USB test on RHEL4" is a known bug and was already fixed, please refer to https://bugzilla.redhat.com/show_bug.cgi?id=455762

This issue only applies to RHEL4. Meaning only the "RHEL4 USB testing" should utilize hts-5.2-20.

hts-5.2-16 can plan the USB test correctly on RHEL5. Since hts-5.2-20 is a preview release, so all USB testing on RHEL5 should be done with hts-5.2-16 .

closing this bug as duplicate with bug#455762

*** This bug has been marked as a duplicate of 455762 ***

Comment 14 IBM Bug Proxy 2008-10-27 16:21:02 UTC
Since this bug has been addressed in version hts-5.2-20.el4 with the patch, RedHat and HIen have all confirmed it is indeed fixed on hts-5.2-20.el4, I will close this bug now.  Thanks everyone!

Comment 16 errata-xmlrpc 2008-11-12 19:24:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0919.html


Note You need to log in before you can comment on or make changes to this bug.